Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema ListBox
BildScreenshot zu ListBox ListBox-Seite mit Beispielarbeitsmappe aufrufen

Summe aus einer Matrix in bestimmtem Wertebereich


Betrifft: Summe aus einer Matrix in bestimmtem Wertebereich von: Max Schoonover
Geschrieben am: 02.05.2017 22:56:40

Hallo,

habe nun lange herumgeknobelt, komme aber nicht drauf:
https://www.herber.de/bbs/user/113257.xlsx

Ich benötige die Summe aller Werte, welche sich in den Zeilen über "Start Tag" und "End Tag" und in der Spalte über den %-Wert definieren.

Ich weiss zwar, wie ich mit der Index/Vergleich Formel einen bestimmten Zellwert aus der Mstrix herauslese, schaffe es aber nicht, daraus die Summe eines bestimmten Matrix-Bereichs zu kalkulieren.

Vielen Dank vorab für Eure Hilfe!
Max

  

Betrifft: AW: Summe aus einer Matrix in bestimmtem Wertebereich von: Uduuh
Geschrieben am: 02.05.2017 23:43:04

Hallo,
=SUMME(INDEX(B2:L17;VERGLEICH(A21;A2:A17;);VERGLEICH(C21;B1:L1;)):INDEX(B2:L17;VERGLEICH(B21;A2:A17;) ;VERGLEICH(C21;B1:L1;)))

Geht wahrscheinlich einfacher

Gruß aus’m Pott
Udo



  

Betrifft: AW: Summe aus einer Matrix in bestimmtem Wertebereich von: Rainer
Geschrieben am: 03.05.2017 06:45:56

Hallo Max,

=SUMME(INDEX(1:1048576;VERGLEICH(A21;A:A;0);VERGLEICH(C21;1:1;0)):INDEX(1:1048576;VERGLEICH(B21; _
A:A;0);VERGLEICH(C21;1:1;0)))
das ist die gleiche Formel wie von Udo, sollte aber flexibler sein wenn du die Größe der Matrix anpassen willst.

"1048576" ist die maximale Zeilenzahl, das klappt ab Office 2007. 2003 hatte nur 65536.

Gruß,

Rainer


  

Betrifft: AW: Summe aus einer Matrix in bestimmtem Wertebereich von: Max Schoonover
Geschrieben am: 03.05.2017 11:20:49

Super - vielen Dank Euch allen, es hat geklappt! :)

Gruss
Max


  

Betrifft: AW: dann ist der thread auch nicht mehr offen owT von: ... neopa C
Geschrieben am: 03.05.2017 11:27:38

Gruß Werner
.. , - ...


  

Betrifft: AW: kürzer mit SUMMENPRODUKT() oder ... von: ... neopa C
Geschrieben am: 03.05.2017 08:11:52

Hallo Max,

... mit SUMME() von INDEX(), wenn wie in Deinem Fall die Daten in Spalte A sortiert sind. Anderenfalls (unsortierte Daten in Spalte A) nimm die Formel von Udo oder Rainer.

=SUMME(INDEX(B2:M19*(B1:M1=C21)*(A2:A19<=A21)*(A2:A19>=B21);)) bzw.

=SUMMENPRODUKT(B2:M19*(B1:M1=C21)*(A2:A19<=A21)*(A2:A19>=B21))

Gruß Werner
.. , - ...


Beiträge aus den Excel-Beispielen zum Thema "Summe aus einer Matrix in bestimmtem Wertebereich "