VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Werte eins bestimmten Monats summieren

Gruppe

Matrix

Bereich

Matrixfunktion

Thema

Werte eins bestimmten Monats summieren

Problem

Wie kann ich, wenn ich in Spalte A die Tage eines Jahres im Datumformat und in Spalte B zu jedem Tag einen Wert eingetragen habe, die Summe der Werte des in Zelle C2 hinterlegten Monats feststellen?

Lösung

Folgende Matrix-Formel: =SUMME(((MONAT(A1:A365))=C2)*(B1:B365))




StandardModule: Modul1

Sub Markierne()
   Dim rng As Range
   Set rng = Range("A1").CurrentRegion
   Dim iRow As Integer, iColC As Integer, iCol As Integer
   
   
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Matrix und Matrixfunktion