Text ausgeben wenn spezielle Bedingungen erfüllt

Bild

Betrifft: Text ausgeben wenn spezielle Bedingungen erfüllt
von: Christian
Geschrieben am: 29.06.2015 14:22:20

Hallo an alle,
ich hoffe ihr könnt mir mit einer Formel aushelfen.
Es geht um folgendes, es soll überprüft werden ob in Tabelle2!A1 und folgende (im Original ca. bis Zeile 5300) einer der Texte aus Tabelle3!A1:A50 steht und gleichzeitig keiner der Texte aus Tabelle3!B1:B4.
Wenn dies zutrifft soll der Text der in Tabelle3 Spalte A als Teil des Textes in Tabelle 2 Spalte A gefunden wurde ausgegeben werden.
Es gibt eine Ausnahme in manchen Zellen steht Troisdorf-Bergheim
sowohl Troisdorf als auch Bergheim stehen in der Liste der zu suchenden Begriffe, in diesem Fall soll Troisdorf ausgegeben werden.
Kann mir da jemand helfen?
Viele Grüße und danke
Chris
https://www.herber.de/bbs/user/98545.xlsx
In Tabelle2 Spalte B steht nochmal händig die gewünschte Ausgabe mit Erklärungen

Bild

Betrifft: mit AGGREGAT(), VERGELICH() und WENNFEHLER() ...
von: der neopa C
Geschrieben am: 29.06.2015 14:55:54
Hallo Christian
... und benutzerdefinierten Zahlenformat: 0;; in der Ergebniszelle und folgender nach unten kopierbarer Formel:
=WENNFEHLER(--(AGGREGAT(15;6;VERGLEICH("*"&Tabelle3!B$1:B$9&"*";A1;)/(Tabelle3!B$1:B$9<>"");1)-1);WENNFEHLER(INDEX(Tabelle3!A:A;AGGREGAT(15;6;ZEILE(A$1:A$99)/ISTZAHL(VERGLEICH("*"&Tabelle3!A$1:A$50&"*";A1;));1););""))
Gruß Werner
.. , - ...

Bild

Betrifft: kürzer, wenn zusätzlich noch SUCHEN() ...
von: der neopa C
Geschrieben am: 29.06.2015 15:02:05
Hallo Christian,
... und zwar dann so:


=WENNFEHLER((AGGREGAT(15;6;SUCHEN(Tabelle3!B$1:B$9;A1)/(Tabelle3!B$1:B$9<>"");1)>0)-1; _
WENNFEHLER(INDEX(Tabelle3!A:A;AGGREGAT(15;6;ZEILE(A$1:A$99)/ISTZAHL(VERGLEICH("*"&Tabelle3!A$1:A$50&"*";A1;));1););""))

(wobei in der ersten Formel die doppelte Negation auch wegfallen könnte).
Gruß Werner
.. , - ...

Bild

Betrifft: AW: kürzer, wenn zusätzlich noch SUCHEN() ...
von: Christian
Geschrieben am: 29.06.2015 15:19:51
Hallo Werner,
wow, das hätt ich alleine nie hinbekommen, danke schonmal,
leider einen kleinen Schönheitsfehler hats doch,
die Formel gibt bei mir in B4 Bergheim statt Troisdorf aus.
Gruß
Christian

Bild

Betrifft: könnte es noch mehr derartige Ausnahmen geben? ..
von: der neopa C
Geschrieben am: 29.06.2015 15:35:00
Hallo Christian,
... sorry erst einmal, dass mit ich das mit Bergheim übersehen hatte..
Wenn es nur die eine Ausnahme gibt, dann kann man sich leicht helfen. Wenn es mehrere derartige gibt, bräuchte ich entweder eine Art Logik (was wann zuerst, die es aber höchstwahrscheinlich nicht gibt).
Schnell und einfach helfen könnte man sich z.B dadurch, dass in Tabelle 3 diese jeweiligen wenigen Suchbegriffe nicht alphabetisch sortiert gelistet werden sondern in der Reihenfolge wie sie als Ergebnis ermittelt werden sollen.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: könnte es noch mehr derartige Ausnahmen geben? ..
von: Christian
Geschrieben am: 29.06.2015 15:45:34
Hallo Werner,
nein ds ist die einzig mir bekannte Ausnahme,
habs mir jetzt ganz einfach gemacht, gefiltert welche Zeilen auf Troisdorf-Bergheim enden, waren nur 2, und da dann händig Troisdorf eingetragen.
Danke trotzdem
Christian

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Text ausgeben wenn spezielle Bedingungen erfüllt"