Live-Forum - Die aktuellen Beiträge
Datum
Titel
17.06.2024 19:56:24
17.06.2024 19:39:46
Anzeige
Archiv - Navigation
1724to1728
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Formel ändern, nur positive Werte summieren

Formel ändern, nur positive Werte summieren
06.12.2019 00:55:34
Burghard
Hallo,
ich möchte gerne nachfolgende Formel erweitern:
=SUMMENPRODUKT((JAHR($A$2:$A$65536)=2019)*(MONAT($A$2:$A$65536 )=10)*$D$2:$D$65536)
und zwar sollen im Ergebnis nur positive Werte in der Spalte summiert werden.
Die obige Formel summiert negative und positive Zahlen.
Hilfe wäre nett.
Grüße
Burghard

10
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Formel ändern, nur positive Werte summieren
06.12.2019 01:05:21
SF
Hola,
....($D$2:$D$65536>0)....

Gruß,
steve1da
AW: Kennt Deine XL-Vers. schon SUMMEWENNS() ? ...
06.12.2019 10:28:21
neopa
Hallo Burghard,
... wenn Du wirklich 65536 Datensätze auswerten willst, könntest Du mit SUMMEWENNS() schneller auswerten lassen. Bei Einsatz von SUMMENPRODUKT() solltest den Bereich auf das wirklich notwendige reduzieren
Gruß Werner
.. , - ...
AW: Kennt Deine XL-Vers. schon SUMMEWENNS() ? ...
06.12.2019 13:18:43
Burghard
Hallo Werner,
danke für den Hinweis. Nein, ich brauche nicht 65536 Zeilen (200 reichen), ich dachte Excel begrenzt die Ausrechnung automatisch auf die letzte ausgefüllte Zeile. Ich habe (leider) noch die alte Excel 2000-Version. Die kennt "Summewenns" noch nicht.
Grüße
Burghard
Anzeige
AW: dann SUMMENPRODUKT() ...
06.12.2019 13:25:03
neopa
Hallo Burghard,
... für z.B. Auswertung bis max Zeile 99 (entsprechend Bedarf anpassen) so:
=SUMMENPRODUKT((JAHR($A$2:$A$99)=2019)*(MONAT($A$2:$A$99)=10)*($D$2:$D$99&gt0);$D$2:$D$99)
Gruß Werner
.. , - ...
AW: dann SUMMENPRODUKT() ...
06.12.2019 22:36:44
Burghard
Danke Werner, diese Lösung funktioniert richtig und wie gewünscht. :-)
Grüße
Burghard
AW: bitteschön owT
07.12.2019 10:48:06
neopa
Gruß Werner
.. , - ...
AW: Formel ändern, nur positive Werte summieren
06.12.2019 13:15:02
Burghard
Hallo Steve,
danke für den Lösungsansatz. Dachte ich auch so, Excel rechnet dann aber bei mir falsch. Geht also leider so nicht. :-(
Viele Grüße
Burghard
AW: Formel ändern, nur positive Werte summieren
06.12.2019 13:26:27
SF
Hola,
also bei mir funktioniert das:
=SUMMENPRODUKT((JAHR($A$2:$A$65536)=2019)*(MONAT($A$2:$A$65536 )=10)*($D$2:$D$65536>0)*$D$2:$D$65536) 

Leider hilft "Excel rechnet falsch" und "geht nicht" niemandem weiter.
Gruß,
steve1da
Anzeige
AW: sollte man so aber vermeiden owT
06.12.2019 15:00:32
neopa
Gruß Werner
.. , - ...
AW: Formel ändern, nur positive Werte summieren
06.12.2019 22:39:36
Burghard
Danke Steve1da, funktioniert jetzt so auch bei mir. Hatte ich vorher etwas falsch gelesen?
Grüße
Burghard

322 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige