Matrix Summenfunktion mit Datum

Bild

Betrifft: Matrix Summenfunktion mit Datum
von: Rolf
Geschrieben am: 26.10.2003 14:48:00

Hi ,
ich möchte nur die Summen SpalteC addieren, die
in SpaltA = A und
Spalte B = 01.06.2001 sind.
Hat einer ne Idee was bei meiner Formel falsch ist. Mein Ergebnis
ist 0. Es muss mit dem Datum zusammenhängen ?

Vielen Dank Rolf

{=SUMME((Tabelle1!A2:A10="A")*(Tabelle1!B2:B10="01.06.2001")*Tabelle1!C2:C10)}
Sp.A --- Sp.B --- Sp.C
A --- 01.06.2001--- 10
A --- 01.06.2001--- 10
A--- 01.06.2001--- 10
A--- 01.06.2002--- 10
E--- 01.06.2002--- 10
E--- 01.06.2003--- 10
E--- 01.06.2003--- 10
E--- 01.06.2003--- 10

Bild


Betrifft: AW: Matrix Summenfunktion mit Datum
von: M@x
Geschrieben am: 26.10.2003 15:01:27

Hi Rolf

=SUMMENPRODUKT((A1:A100="A")*(B1:B100=DATWERT("01.10.2003"))*(C1:C100))

Gruss

M@x


Bild


Betrifft: AW: Matrix Summenfunktion mit Datum
von: Rolf
Geschrieben am: 26.10.2003 15:18:41

Hi Max,
erst mal Danke. Ich hab aber folgendes Problem.
Deine Formel mit DATWERT funkt. Wenn ich die über VBA umsetzten
will sieht der Ausschnitt so aus. Funkt auch.
(R[2]C[-4]:R[9]C[-4]=DATEVALUE(""01.06.2001""))

Aber wenn ich das Datum flexibel halten will durch StringVaribale Dat
sieht das so aus und funkt nicht. WIESO ???
Dat = "01.06.2001"
(R[2]C[-4]:R[9]C[-4]=DATEVALUE(" & Dat & "))


Bild


Betrifft: AW: Matrix Summenfunktion mit Datum
von: Björn B.
Geschrieben am: 26.10.2003 21:23:17

Hallo Rolf,

bin zwar nicht Max, aber macht hoffentlich auch nix.

Versuchs doch mal mit:

Dat = "01.06.2001"
(R[2]C[-4]:R[9]C[-4]=DATEVALUE(Dat))

Gruß
Björn


Bild


Betrifft: AW: Matrix Summenfunktion mit Datum
von: DieterL
Geschrieben am: 26.10.2003 15:11:44

Hallo Rolf,

Probiere mal folgendes:

{=SUMME(WENN(A2:A10="A";WENN(B2:B10=E3;C2:C10;0);0))}

dabei steht in Zelle E3 Das Datum das du rausfiltern und summieren möchtest.


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Matrix Summenfunktion mit Datum"