Microsoft Excel

Herbers Excel/VBA-Archiv

Summe jeder x-ten Zelle wenn bestimmtes Jahr | Herbers Excel-Forum


Betrifft: Summe jeder x-ten Zelle wenn bestimmtes Jahr von: Lilly
Geschrieben am: 23.07.2012 11:31:36

Hallo miteinander,

habe folgendes Problem:

Ich habe ein Blatt "Datenarchiv" worin mit der Zeit Daten gesammelt werden. In der ersten Zeile habe ich immer je zwei Spalten (beginnend mit A1:B1) verbunden und diese "24 Monate", "36 Monate" etc. benannt und so eine Tabelle aufgebaut. Abzüglich der ersten Zeile umfasst die Tabelle den Bereich A2:L15. Mit jedem neuen Datensatz wird eine weitere Tabelle mit gleichem Aufbau unten drangehängt (also A16:L29, A30:L43 etc.).
In den "geraden" Spalten (also B, D, F, etc.) stehen Werte und in den "ungeraden" Spalten die jeweilige Bezeichnung.

Nun habe ich in Zelle A5 "Rücklauftermin" und in B5 das entsprechende Datum im Format MMM JJ (z.B. Jan 13).

In Zelle B7 habe ich ein Volumen in Stück und in B13 ein Volumen in Geldeinheiten. Ich würde gerne in einem anderen Blatt abhängig vom Jahr des Rücklauftermins die jeweilige Summe der Volumina bilden.
Beispiel: 24 Monate (Bereich A:B), bilde Summe für Rückläufer in 2013

Tabelle 1 Rücklauftermin Jan 2013, 15 Stück und 370'000 €
Tabelle 2 Rücklauftermin Jan 2015, 25 Stück und 500'000 €
Tabelle 3 Rücklauftermin Sep 2013, 10 Stück und 260'000 €

Es soll jetzt in einem Blatt "Risiken-Chancen" in die Zelle B3 die Summe des Volumens in Stück, also 25 und in B8 die Summe des Volumen in Geldeinheiten, also 630'00 € eingetragen werden. Automatisch oder über einen Button, beides wäre in Ordnung.

Habe schon einiges versucht in Excel (=summewenn, {=SUMME(WENN(REST(ZEILE...}) aber leider ohne Erfolg.
Werde wohl nicht um vba rumkommen.

Hoffe die Beschreibung ist nicht zu konfus und ihr könnt mir hier weiterhelfen.

Beste Grüße
Lilly

  

Betrifft: Beispieldatei?? von: UweD
Geschrieben am: 23.07.2012 12:59:19

...


  

Betrifft: AW: Beispieldatei?? von: Lilly
Geschrieben am: 23.07.2012 13:18:50

Hier eine Beispieldatei:

https://www.herber.de/bbs/user/81133.xls

Die Daten werden in das Blatt "Übersicht" eingetragen und mit einem Klick auf den Button in "Datenarchiv" kopiert.


  

Betrifft: AW: Summe jeder x-ten Zelle wenn bestimmtes Jahr von: Jack
Geschrieben am: 27.07.2012 09:54:48

Hallo Lilly

also wenn ich dich richtig verstanden hab geht es nur um die Summation verschiedener Werte wenn sie vorhanden sind.
hast du es schonmal mit Summewenns probiert?
Bin mir aber grad nicht sicher ob es die schon in der 03er Version gab.

Grüße