Microsoft Excel

Herbers Excel/VBA-Archiv

Summe wenn Datum usw

Betrifft: Summe wenn Datum usw von: Lupo
Geschrieben am: 31.07.2014 12:41:58

Hallo
möchte folgende Anzahl wenn

Spalte D sind die Datumswerte (Buchungen) und in der Spalte E die Gutschriften oder Rechnungen. Rechnungen sind natürlich immer die Werte über Null und die Gutschriften unter Wert Null ( also minus).

Ich brauche die Anzahl der Rechnungen abgezogen die Anzahl der Gutschriften in einem bestimmten Zeitraum. Den Zeitraum kann ich immer in der Formel beliebig ändern.

Danke vorerst

  

Betrifft: AW: Summe wenn Datum usw von: MCO
Geschrieben am: 31.07.2014 13:35:48

Mahlzeit!

Probiers mal damit:

Formel mit Bezug auf Bereich:

=ZÄHLENWENN(E8:E30;">0")-ZÄHLENWENN(E8:E30;"<0")
Formel mit Bezug auf Datum (Anfangsdatum u. Enddatum) in den Feldern G8 bzw G9
=ZÄHLENWENNS(E8:E30;">0";D8:D30;"<="&G8;D8:D30;">="&G9)-ZÄHLENWENN(E8:E30;"<0")
Gruß, MCO


  

Betrifft: Zählenwenn wenn Datum usw von: ChrisL
Geschrieben am: 31.07.2014 13:37:50

Hi Lupo

Ab Excel 2007:

G1 Beginndatum
G2 Enddatum

=ZÄHLENWENNS(D:D;">"&G1;E:E;">0";D:D;"<"&G2)-ZÄHLENWENNS(D:D;">"&G1;E:E;"<0";D:D;"<"&G2)

Evtl. musst du Grösser in Grösser/Gleich resp. Kleiner/Gleich ändern.

cu
Chris


  

Betrifft: AW: Summe wenn Datum usw von: Matze Matthias
Geschrieben am: 31.07.2014 13:39:27

Hallo Lupo,
Summenprodukt:




Tabelle1

 DEFGH
1    'von'bis 
201.07.201410001.07.201409.07.2014540
302.07.2014-50     
403.07.2014200     
504.07.2014-30     
605.07.2014100     
706.07.2014-50     
807.07.2014200     
908.07.2014-30     
1009.07.2014100     

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
H2=SUMMENPRODUKT((E2:E21) *(D2:D21>=F2) *(D2:D21<=G2) )   =SUMPRODUCT((RC[-3]:R[19]C[-3]) *(RC[-4]:R[19]C[-4]>=RC[-2]) *(RC[-4]:R[19]C[-4]<=RC[-1]) )

XHTML Tabelle für Darstellung in Foren,
einschl. Bedingter Formatierung ab Version 2007
XHTML-Version 11.50 einschl 64 Bit Version


2007
XHTML-Version 11.50 einschl 64 Bit Version



Matze


  

Betrifft: ooops - anzahl war gefragt sorry, owT von: Matze Matthias
Geschrieben am: 31.07.2014 13:41:30




  

Betrifft: AW: Summe wenn Datum usw von: Lupo
Geschrieben am: 31.07.2014 15:26:05

Leider nich wie ich mir das vorstelle.
Ich sende ein File zum nschauen mit.
https://www.herber.de/bbs/user/91815.xls

Danke
LG


  

Betrifft: AW: Summe wenn Datum usw von: ChrisL
Geschrieben am: 31.07.2014 16:03:41

Hi Lupo

Hauptproblem ist, dass in deinem File die Spalten D:E keine richtige Zahlen sind, sondern als Text interpretiert.

Füge in eine leere Zelle die Zahl "1" ein. Kopiere diese Zelle. Markiere Spalten D:E, rechte Maustaste, Inhalte einfügen, multiplizieren.

Formel:
=ZÄHLENWENNS(D:D;">=20140516";E:E;">0";D:D;"<=20140522")

cu
Chris


  

Betrifft: AW: Summe wenn Datum usw von: Lupo
Geschrieben am: 01.08.2014 10:55:00

Funktioniert - Danke vielmals