summewenn mit Monat

Bild

Betrifft: summewenn mit Monat
von: Heinz
Geschrieben am: 28.02.2005 11:20:17
Hallo,
folgendes Tabellenblatt sei gegeben:
A B C
01.01.2005 1 10
01.03.2005 3 5
01.02.2005 2 50
01.03.2005 3 10
aus einem anderen Blatt heraus will ich die Summen monatsweise (Monat ist in Spalte B) bilden
d.h. für 01 = 10, für 02 = 50 und für 03 = 15.
Ich wollte mit der Funktion summewenn arbeiten; d.h. summewenn(month;1; hours) liefert mir den korrekten Wert.
month = Bereich (B:B)
hours = Bereich (C:C)
Ich möchte nun aber die Spalte B "einsparen", d.h. in meine summewenn-Formel die Funktion Monat implementieren, d.h. summewenn(monat(date);1; hours)
date = Bereich (A:A). Hier wird mir immer ein Formelfehelr geliefert; wer kann mir helfen?
Danke für Hilfe,
Heinz

Bild

Betrifft: AW: summewenn mit Monat
von: HermannZ
Geschrieben am: 28.02.2005 11:31:25
Hallo heinz,
oder du sparst beide Spalten ein,
Beispiel;
DatumZeitMuster
 ABCD
2093    
209401.01.2005 10<< Monat 1
209501.03.2005 30<< Monat 3
209601.02.2005 50<< Monat 2
209701.03.2005   
2098    
Formeln der Tabelle
C2094 : {=SUMME((MONAT(A2094:A2097)=MONAT(A2094))*10)}
C2095 : {=SUMME((MONAT(A2094:A2097)=MONAT(A2095))*15)}
C2096 : {=SUMME((MONAT(A2094:A2097)=MONAT(A2096))*50)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß hermann
Bild

Betrifft: AW: summewenn mit Monat
von: Heinz
Geschrieben am: 28.02.2005 12:35:41
Hallo,
danke für Deine Hilfe; vielleicht habe ich mich undeutlich ausgedrückt; Spalte C soll addiert werde, d.h. die Werte sind variabel. Aus diesem grunde kann ich nicht in der Formel mit diesen Werten statisch arbeiten.
Hast Du noch eine Idee?
MfG,
Heinz
Bild

Betrifft: AW: summewenn mit Monat
von: Sigrid
Geschrieben am: 28.02.2005 13:07:23
Hallo, Heinz und Hermann,
ich mache folgenden Vorschlag:
= Summe(wenn(monat(a1:a4)=Zeile(1:1);b1:b4;""))
(als Matrixformel in c1 eintragen und mit STRG, UMSCH und ENTER abschließen).
Zellbezüge müßten angepaßt werden, der Ausdruck Zeile(1:1) _nicht_.
Formel kopieren, soweit nötig.
Viel Erfolg!
Grüße
Sigrid
Bild

Betrifft: AW: summewenn mit Monat
von: HermannZ
Geschrieben am: 28.02.2005 16:44:11
Hallo Heinz,
das verstehe ich jetzt nicht ganz,du schreibst:
in Spalte A ist Datum
in Spalte B ist der Monat aus Spalte A
in Spalte C der Wert für den einzelnen Monat 1= 10, 2=50 3=15 usw;
wenn dem so ist ist meine Formel richtig, denn wenn in Spalte A der Monat =1 wird diese Anzahl der Eintagungen in Spalte A mit 10 Multipliziert genauso für die anderen Moante.
Du siehst das auch an dem Monat 3 da gibt es zwei Eintagungen und somit ist das Ergebniss 2 * 15 = 30 oder???
Gruß hermann
Bild

Betrifft: AW: summewenn mit Monat
von: Heinz
Geschrieben am: 28.02.2005 16:51:30
Hallo Hermann,
die Idee ist folgende:
in Spalte A steht das Datum, in Spalte C Werte. In einem anderen Tabellenblatt will ich die Summen für die einzelnen Monate (von 1 - 12) sammeln. Spalte B ist nur eine "Hilfsspalte", die mir meine gewünschte Funktionalität ohne Monatsermittlung in Summewenn liefert. Ich möchte letztendlich OHNE Spalte B auskommen.
Verstehst Du nun mein Problem?
Übrigens: Vielen Dank für Dein bisheriges Engangement!
MfG,
Heinz
Bild

Betrifft: AW: summewenn mit Monat
von: HermannZ
Geschrieben am: 28.02.2005 17:11:36
Hallo Heinz,
ein anderes Beispiel hier wird die Spalte C addiert wenn in Spalte A der Monat 1
Beispiel;
DatumZeitMuster
 ABCD
2099    
2100    
210101.01.2005 10 
210201.03.2005 20 
210301.02.2005 30 
210401.03.2005 40 
210501.01.2005 50 
210601.03.2005 60 
210701.02.2005 70 
210801.03.2005 80 
210901.01.2005 90 
2110    
2111 150<< Ergeniss für Monat 1 
2112    
Formeln der Tabelle
B2111 : {=SUMME((MONAT(A2101:A2109)=MONAT(A2094))*C2101:C2109)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß hermann
Bild

Betrifft: AW: summewenn mit Monat
von: Heinz
Geschrieben am: 01.03.2005 08:04:30
Hallo Herrmann,
ich habe mal die Datei hochgeladen...
https://www.herber.de/bbs/user/18970.xls
Im Sheet Summary stehen in Spalte A die Monate 1 - 12
In Spalte B stehen die summierten Werte je Monat aus dem Bereich HOURS aus dem Sheet Details.
Die Ermittlung erfolgt über die Hilfsspalte B (MONTH) im Sheet Details.
Dieses möchte ich aber vermeiden; ich möchte die Summierung OHNE Hilfsspalte B.
Ist das Problem nun deutlicher?
Falls Du möchtest (und es nicht zuviel verlangt ist!) kannst Du mich anrufen; ich rufe sofort zurück: 02103-2002-130 Heinz Schikorra
Vielen Dank,
Heinz
Bild

Betrifft: AW: summewenn mit Monat
von: HermannZ
Geschrieben am: 01.03.2005 18:00:32
Hallo Heinz,
bin zur Zeit nicht zu Hause Telefonieren schlecht.
habe es einmal geändert,arbeite aber zur Zeit hier mit der deutschen Version,
du musst die Funktion in engliche übersetzen.wenn das schwierigkeiten macht melde dich.
hier die geänderte Formel-----=SUMME((MONAT(Details!$A$2:$A$8)=1)*(Details!$F$2:$F$8))
Gruß Hermann
Bild

Betrifft: AW: summewenn mit Monat
von: Heinz
Geschrieben am: 02.03.2005 09:17:29
Hallo,
ganz klappt es immer noch nicht:
=SUMME((MONAT(Details!$A$2:$A$8)=1)*(Details!$G$2:$G$8)) liefert mir immer die 1 als Ergebnis...
ich habe die Formel etwas modifiziert:
SUMME((MONAT(month)=A11)*(hours)); Ergebnis ist aber imemr noch falsch; hast Du noch eine Idee?
Anmerkung: Die Ergebnisse in Spalte B von Sheet Summary sind korrekt; genau diese benötige ich; ich will nur die Monatsermittlung nicht als separates Feld haben, sondern in der Formel abhandeln...
MfG,
Heinz
Bild

Betrifft: AW: summewenn mit Monat
von: HermannZ
Geschrieben am: 02.03.2005 10:48:34
Hallo Heinz,
die Formel ist eine Marix-Formel, sie muss mit STR+SHIFT+RETURN abgeschlossen werden.
erst dadurch wird die Formel zu einer Matrixformel.
gruß hermann
Bild

Betrifft: AW: summewenn mit Monat
von: Heinz
Geschrieben am: 02.03.2005 11:24:27
Super! es klappt, vielen Dank.
meine Formel lautet nun:
={SUMME((MONAT(Details!$A$2:$A$65000)=A11)*(Details!$F$2:$F$65000))}
Ich habe versucht den Bereichen Namen zu geben, d.h.
Leistungsdatum = Details!$A$2:$A$65000
costs = Details!$F$2:$F$65000
und dann versucht diese in die Formel zu implementieren:
={SUMME((MONAT(Leistungsdatum)=A11)*(costs))}
Dieses war jedoch nicht von Erfolg gekrönt; hast Du noch eine Idee? (Nur, wenn möglich; mein Problem ist 100%ig gelöst, ist nur ein "Nice")
Herzlichen Dank!
Heinz
Bild

Betrifft: AW: summewenn mit Monat
von: HermannZ
Geschrieben am: 02.03.2005 14:21:34
Hallo Heinz,
das geht auch,du must nur vor dem Namen des Bereichs dem Mappennamen verwenden ein Beispiel,--{=SUMME((Vorlage.xls!TestA=1)*Vorlage.xls!TestB)} hier ist Vorlage.xls wie du sicher erkennst der Mappenname und TestA und TestB der Bereichsname, wenn du das so verwendest dann geht das.( Abschluss als Matrix nicht vergessen)
Gruß hermann
 Bild

Beiträge aus den Excel-Beispielen zum Thema "summewenn mit Monat"