Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Werte auslesen mit Bedingungen

Werte auslesen mit Bedingungen
23.10.2022 12:11:31
Marko
Hallo in die Runde,
aus einer Tabelle möchte ich unter der Bedingung (der % Wert ist größer als 0) den dazugehörigen Wert auslesen und in eine andere Zelle übertragen. Dazu möchte ich den % Wert, wenn vorhanden auslesen und ebenfalls in eine andere Zelle übertragen. Eine Beispieldatei habe ich angefügt. Wie kann ich das Thema lösen. Vielen Dank für Eure Unterstützung, besten Gruß, Marko
https://www.herber.de/bbs/user/155801.xlsx

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Werte auslesen mit Bedingungen
23.10.2022 14:32:51
RePeter
Schreibe in Deine Zelle C5
=INDEX($F$1:$AM$8;GANZZAHL(MIN(WENN($F$1:$AM$8=B5;ZEILE(1:8)+SPALTE(F:AM)/999))); REST(MIN(WENN($F$1:$AM$8=B5;ZEILE(1:8)+SPALTE(F:AM)/999));1)*999+1-5)
und schließe die Formel mit Strg-Umschalt-Return ab (Matrixformel)
Dann Formel nach unten kopieren.
So sollte es bei Deinen Datenstrukturen klappen.
VG RePeter
AW: Werte auslesen mit Bedingungen
23.10.2022 20:06:36
RePeter
Ich ziehe zurück,,,hatte überlesen, dass Du beide Werte (€ und %) suchen und finden willst und war daher fälschlicherweise davon ausgegangen, dass der €-Wert schon "gesetzt" sei. Werners Lösung unten ist also die richtige und vollständige,
VG RePeter
Anzeige
AW: beide Werte können ermittelt werden ...
23.10.2022 19:16:34
neopa
Hallo Peter,
... in B5: =WENNFEHLER(AGGREGAT(15;6;F5:AL5/(G5:AM5&gt0)/(F$3:AL$3="€");1);"") und
in C5 einfach: =WENNFEHLER(INDEX(5:5;VERGLEICH(B5;F5:AL5;0)+6);"")
beide Formeln nach unten ziehend kopieren.
Gruß Werner
.. , - ...

319 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige