Microsoft Excel

Herbers Excel/VBA-Archiv

zählenwenns ohne doppelte werte

Betrifft: zählenwenns ohne doppelte werte von: Jana
Geschrieben am: 15.10.2014 10:50:19

Hallo, ich habe folgendes Problem.

ich habe an Hand einer häufigkeitsformel versucht Fallnummern zu zählen. in meiner Datei sind allerdings auch doppelte Fallnummern, die aber nur einmal gezählt werden sollen.
hinzukommt, dass die Funktion mehrere Kriterien berücksichtigen soll. Die Formel die ich habe, sah auch anfangs ganz gut aus, im Plausicheck stellte sich dann aber später raus, dass sie nicht richtig ist.
ich habe mal eine Beispieldatei hochgeladen. bei der Überprüfung sieht man z.b. dass bei A_TKS STAT3a im ersten Quartal eine "1" errechnet wurde, sucht man aber danach im ersten tabellenblatt, gibt es dort keine fallnummer.

kann mir jemand helfen?

https://www.herber.de/bbs/user/93178.xlsx

  

Betrifft: nicht ZÄHLENWENNS() sondern mit HÄUFIGKEIT() ... von: neopa C (paneo)
Geschrieben am: 15.10.2014 15:32:13

Hallo Jana,

... die Basis Deiner Formel ist schon mal die richtige Richtung. Allerdings sollte da noch ein WENN() eingefügt werden, was die Teilhäufigkeiten auf das richtige Maß reduziert. Die Häufigkeit je Abteilung würde ich dann schlicht mit der einfachen SUMME() der Teilhäufigkeiten ermitteln, denn offensichtlich tauchen auch gleiche Fallnummern in verschiedenen Stationen der Abtl. "A_Psych" auf (und da ergibt die Matrixformel eine geringer Anzahl als die Summe der Anzahl der Stationen). Hab das jetzt nicht im Detail nachgeprüft. Ist das der Fall?

Für die Abteilung "A_TKS" ist das nicht der Fall. Hier in D9:

{=SUMME((HÄUFIGKEIT(WENN((Tabelle1!$D$2:$D$906=Tabelle2!$A9)*(Tabelle1!$E$2:$E$906=Tabelle2!$B9) *(Tabelle1!$C$2:$C$906<("31.3.2014")*1);Tabelle1!$A$2:$A$906);Tabelle1!$A$2:$A$906)>0)*1) }
und nach unten kopieren

Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "zählenwenns ohne doppelte werte"