Microsoft Excel

Herbers Excel/VBA-Archiv

Sortieren von Werten

Betrifft: Sortieren von Werten von: Bene S.
Geschrieben am: 15.10.2014 10:41:26

Hallo Zusammen,

Ich habe ein Problem, welches so ähnlich schon mal behandelt wurde mit gleichem Betreff.

Problem: Ich habe eine Spalte mit Referenzwerten. Die Spalten neben dieser Spalte entahlten ebenfalls diese Referenzwerte mit ihren Eigenschaften (Buchstaben), jedoch können diese in einer anderen Reihenfolge stehen, mehrmals oder gar nicht auftauchen. Ich will die Werte mit ihren Eigenschaften in den Folgespalten so sortiert haben, dass sie an der gleichen Position und in ihrer Anzahl wie in der Referenzspalte stehen.

Anbei ein Excel-File, Welches das Problem veranschaulicht. Hier habe ich ein Beispiel mit Ist und Soll gemacht.

https://www.herber.de/bbs/user/93177.xlsx

Vielen Dank und viele Grüße
Bene

  

Betrifft: mit Formel(n) realisierbar, ... von: neopa C (paneo)
Geschrieben am: 15.10.2014 15:38:52

Hallo bene,

... doch dazu vorher nachgefragt.

Jede "Eigenschaften" würde danach in einer Zelle stehen. D.h. anstelle einer Excelspalte (z.B. Spalte L) können im Beispiel bis zu 3 Spalten (dazu siehe L12) für dies benötigt werden. Wäre das ok für Dich?

Gruß Werner
.. , - ...






  

Betrifft: AW: mit Formel(n) realisierbar, ... von: Bene S.
Geschrieben am: 15.10.2014 19:49:27

Hallo Werner,

ja das wäre auch ok, wenn es nicht anders geht. Danke für deine Mühe.

Viele Grüße
Bene


  

Betrifft: z.B. Matrixformel mit INDEX() und KKLEINSTE() ... von: neopa C (paneo)
Geschrieben am: 16.10.2014 15:59:16

Hallo Benee,

... nachfolgende beide Formeln entsprechend nach rechts und nach unten kopieren.
Aus den beiden Formeln könnte man auch eine machen.

 ABCDEFGHIJKLMNO
3               
4 Ist   
5 Referenz WerteSpalte 1Spalte 2 Referenz WerteZuordnung für Spalte 1Zuordnung für Spalte 2 
6 12e3s 1       
7 25a7e 2e      
8 36c7f 3   s   
9 45b5s 4a  r   
10 54a4r 5ab s   
11 6  7g 6c  h   
12 7  6h 7   efg 
13               
14               

Formeln der Tabelle
ZelleFormel
I6{=WENN(ZÄHLENWENN($C$6:$C$99;$H6)=0;"";WENNFEHLER(INDEX($D:$D;KKLEINSTE(WENN($C$6:$C$99=$H6;ZEILE(A$6:A$99)); SPALTE(A1))); ""))}
L6{=WENN(ZÄHLENWENN($E$6:$E$99;$H6)=0;"";WENNFEHLER(INDEX($F:$F;KKLEINSTE(WENN($E$6:$E$99=$H6;ZEILE(A$6:A$99)); SPALTE(A1))); ""))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: AW: z.B. Matrixformel mit INDEX() und KKLEINSTE() ... von: Bene S.
Geschrieben am: 16.10.2014 23:16:18

Hallo Werner,

super. Vielen Dank. Es klappt wunderbar.

Viele Grüße
Bene


 

Beiträge aus den Excel-Beispielen zum Thema "Sortieren von Werten"