Microsoft Excel

Herbers Excel/VBA-Archiv

Problem SVERWEIS

Betrifft: Problem SVERWEIS von: Marek
Geschrieben am: 15.10.2014 10:30:42

Ich habe eine Tabelle1 mit 2 Spalten

SpalteA Spalte B

Artikel-Nr Artikel-Nr nochmal

1 1
2 2

und eine Tabelle 2 mit 2 Spalten

SpalteA SpalteB

Artikel-Nr Übereinstimmend

1 =SVERWEIS(A2;'Tabelle1'!A2:A614;2)
2

In Tabelle 2 sollte nun der Wert aus Tabelle 1 Spalte B angezeigt werden.

Das passiert aber nicht sondern es kommt eine Fehlermeldung


  

Betrifft: AW: Problem SVERWEIS von: Daniel Eisert
Geschrieben am: 15.10.2014 11:03:10

HI

wenn du die Formel nach unten ziehst, wandert der Zellbereich 'Tabelle1'!A2:A614 mit, weil du den Zellbereich relativ gesetzt hast (dh in der nächsten Zeile ist der Bereich 'Tabelle1'!A3:A615)

du solltest ihn absolut stetzen, dann bleibt er beim Ziehen fix: 'Tabelle1'!$A$2:$A$614

Gruß Daniel


  

Betrifft: AW: Problem SVERWEIS von: Udo
Geschrieben am: 15.10.2014 11:29:49

Hai,

die Vermutung von Daniel solltest Du auf jeden Fall prüfen.

Dann noch zusätzlich prüfen, dass die Formatierung in den beiden Spalten identisch ist. Ich vermute, dass einmal Zahlen und einmal Texte formatiert ist.

Und ein letzter Hinweis: setzte den 4. Wert der SVerweis-Funktion auf FALSCH, da Du ja eine genaue Übereinstimmung suchst.

Deine Formel sollte dann so lauten:

=SVERWEIS(A2;'Tabelle1'!$A$2:$A$614;2;FALSCH)
Gruß

Udo


  

Betrifft: AW: Problem SVERWEIS von: Marek
Geschrieben am: 15.10.2014 11:35:35

Das setzen des 4. Werts auf FALSCH führt nur dazu, dass anstelle "#NV" jetzt "BEZUG" steht.

Alles ist in TEXT formatiert.


  

Betrifft: AW: Problem SVERWEIS von: Udo
Geschrieben am: 15.10.2014 11:52:56

BEZUG ??

Poste doch einfach mal Deine Datei (Brauchen dann ja nur ein paar Felder in Tab1 und Tab2 Spalte A besetzt sein !Alles andere kannst Du löschen, falls sensible Daten ! )

Ich arbeite viel mit SVerweis und kenne dabei keinen BEZUGS-Fehler. Lediglich #NV !!


  

Betrifft: AW: Problem SVERWEIS von: Udo
Geschrieben am: 15.10.2014 12:04:25

Ahhh, jetzt hab ichs

Ändere mal Deine Formel so ab:

=SVERWEIS(A2;'Tabelle1'!$A$2:$B$614;2;FALSCH)



  

Betrifft: AW: Problem SVERWEIS von: Marek
Geschrieben am: 15.10.2014 11:33:02

Das Problem wird damit nicht behoben


  

Betrifft: welches Problem meinst Du nun ... von: neopa C (paneo)
Geschrieben am: 15.10.2014 15:58:15

Hallo Marek,

... die #NV- Fehlermeldung?

Dann teste mal: =SVERWEIS(A2&"";Tabelle1!$A$2:$B$614;2;FALSCH)

Gruß Werner
.. , - ...


  

Betrifft: Wohl kaum #NV... von: {Boris}
Geschrieben am: 15.10.2014 18:05:03

Hi Werner,

...denn erst eine halbe Stunde nach Markes Antwort hat Udo bemerkt, dass die Matrix nur EINspaltig war (und zudem der 4. Parameter fehlte). Darauf fehlt aber noch die Antwort von Marek.

VG, Boris


  

Betrifft: AW: Wohl kaum #NV... von: Marek
Geschrieben am: 15.10.2014 18:58:49

Das Problem lag an folgendem:

Der Wert in SPalte 1 und 2 in Tabelle 1 war derselbe, somit hatte die Matrix in welcher Gesucht wurde doppelte Werte.

Wie kann ich hier eine Excel Datei hochladen?


  

Betrifft: Steht doch da: 'Zum FileUpload' Wie deutlich ... von: Luc:-?
Geschrieben am: 16.10.2014 04:45:10

…muss dir das denn gesagt wdn, Marek?!
Außerdem kann man ja auch mal auf die Idee kommen, auf FORUM & SERVICES zu klicken!
Morrn, Luc :-?


 

Beiträge aus den Excel-Beispielen zum Thema "Problem SVERWEIS"