Live-Forum - Die aktuellen Beiträge
Datum
Titel
25.06.2024 10:26:31
25.06.2024 08:19:20
Anzeige
Archiv - Navigation
1336to1340
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

ZÄHLENWENN ohne Doppelte

ZÄHLENWENN ohne Doppelte
01.11.2013 10:30:57
P.B.
Hallo liebe Excel Anwender,
ich brauche eure Hilfe.
Ich habe gestern schon bis halb 4 in der Nacht dran gesessen und drehe echt durch. Ich habe ähnliche Beiträge hier gefunden, war aber nicht in der Lage, die dortigen Lösungen irgendwie auf mein Problem zu übertragen:
Ich habe folgende Liste:
Werbemittel X Datum verkettet mit Werbeplattform
B1 01.01.2010A.de
T1 01.01.2010A.de
T20 01.01.2010a.com
T3 01.01.2010a.com
T3 01.01.2010a.com
Sr 01.01.2010br.de
IT 01.01.2010c.de
01.01.2010d.de
T1 01.01.2010d.de
T2 01.01.2010d.de
In jeder Zeile soll gezählt werden, wie oft ein Werbemittel an einem Tag ausgespielt wurde. Doppelte Werbemittel sollen nicht gezählt werden. Auch leere Felder, wo kein Werbemittel bekannt ist sollen nicht gezählt werden.
Am Ende soll dann herauskommen:
B1 01.01.2010A.de 2
T 1 01.01.2010A.de 2
T 20 01.01.2010a.com 2
T3 01.01.2010a.com 2
T3 01.01.2010a.com 2
Sr 01.01.2010br.de 1
IT 01.01.2010c.de 1
01.01.2010d.de 2
T1 01.01.2010d.de 2
T2 01.01.2010d.de 2
Ich hatte schon die Liste nach dem Identifier Datum mit Werbeplattform sortiert und dann über WENN Abfragen 0 und 1 Summen erstellt und die zusammengezählt.
Also z.B. Wenn Werbemittel in Zelle1 Zelle2 UND Identifier in Zelle 1 = Zelle 2 dann schreibe eine 1 sonst 0
Dann hatte ich mit SUMMEWENN gearbeitet.
Das klappte aber immer nur bis zu dem Punkt:
T6 01.01.2011F.de
T6 01.01.2011faaa.de
Stehen solche Ereignisse unmittelbar untereinander kommen bei allen WENN Abfragen 0 Ergebnisse. Dann liefert SUMMEWENN nicht das richtige Ergebnis.
Evtl. hat jemand eine andere elegantere Lösung für oberes Problem?
VG

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
widersprüchliche Angaben ...
01.11.2013 10:51:09
neopa
Hallo,
... ich kann z.B. aus Deinen Beispieldaten nicht erkennen, dass sich "B1 01.01.2010A.de 2" ergibt und wenn sich das wie bei "T3 01.01.2010a.com 2" ergibt, sind diese doppelt (also identisch) und solche willst Du nicht berücksichtigt haben. Du solltest also passende Beispieldaten und Ergebnisdaten angeben. Dann sehen wir weiter.
Gruß Werner
.. , - ...

AW: ZÄHLENWENN ohne Doppelte
01.11.2013 12:40:43
UweD
Hallo
mit einer Hilfspalte habe ich es hinbekommen...
Tabelle1
 ABCD
1WMDatumPlattformHSpErgebnis
2B101.01.2010A.de12
3T101.01.2010A.de12
4T2001.01.2010a.com12
5T301.01.2010a.com12
6T301.01.2010a.com22
7Sr01.01.2010br.de11
8IT01.01.2010c.de11
9  01.01.2010d.de02
10T101.01.2010d.de12
11T201.01.2010d.de12

verwendete Formeln
Zelle Formel Bereich
C2 =ZÄHLENWENNS(A$2:A2;A2;B$2:B2;B2) 
D2 =ZÄHLENWENNS(B:B;B2;C:C;1) 

Tabellendarstellung in Foren Version 5.49


Gruß UweD

Anzeige
ach so war das gemeint; dann auch ohne HS ...
01.11.2013 13:20:19
neopa
Hallo Uwe,
... dank Deiner Interpretation, hab auch ich jetzt verstanden, was das Ziel ist.
Dann ohne Hilfsspalte z.B. folgende Formel in C2 und die nach unten kopieren:
=SUMMENPRODUKT(((VERGLEICH(A$2:A$99&B$2:B$99;A$2:A$99&B$2:B$99;)=ZEILE($1:$98))*(A$2:A$99>0)=1)* _
(B$2:B$99=B2))
Gruß Werner
.. , - ...

308 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige