Live-Forum - Die aktuellen Beiträge
Datum
Titel
17.06.2024 19:56:24
17.06.2024 19:39:46
Anzeige
Archiv - Navigation
1240to1244
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

zählenwenn komm nicht weiter

zählenwenn komm nicht weiter
murat
hallo,
ich bräuchte ne formel die folgendes kann:
sie überprüft ob in der Spalte A der Wert großer 0 und kleiner 100 steht,wenn dies so ist, zählt sie in Spalte B alle Lieferantennummern, aber so dass doppelten oder mehrfach Lieferantennr. nur einmal gezählt werden.
Ich habe u.g. lösung gefunden und angepasst, funktionert aber nicht!
Hallo Murat,
kleine Änderung in der Formel: statt "=4" ">0" und " =SUMME(--(HÄUFIGKEIT(WENN(A1:A100>0;B1:B100);WENN(A1:A100<100;B1:B100))>0))
dann die Formel mit STRG-SHIFT-ENTER eingeben.
Gruß,
Peter

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: zählenwenn komm nicht weiter
12.12.2011 07:54:15
Mag
=SUMME(--(HÄUFIGKEIT(WENN(A1:A10>0;B1:B10);WENN(A1:A10<100;B1:B10))>0))-1
dann die Formel mit STRG-SHIFT-ENTER eingeben.
Gruß
Anzeige
mmmh...
12.12.2011 08:14:44
Erich
Hi Mag,
schau dir mal dieses Beispiel an:
 ABC
1WertLief-NrAnz. versch.
2114
3113
412 
512 
612 
713 
813 
913 
1013 
1114 
1214 
1314 

Formeln der Tabelle
ZelleFormel
C2{=ANZAHL(1/(VERGLEICH(WENN((A2:A13>0)*(A2:A13<100); B2:B13); WENN((A2:A13>0)*(A2:A13<100); B2:B13); 0) *(A2:A13>0)*(A2:A13<100)=ZEILE(1:12)))}
C3{=SUMME(--(HÄUFIGKEIT(WENN(A2:A13>0;B2:B13); WENN(A2:A13<100;B2:B13))>0))-1}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Noch eins: Müssen die Lieferantennummern Zahlen sein? Wenn nicht, versagt HÄUFIGKEIT.
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich
Anzeige
AW: mmmh...
12.12.2011 09:14:18
Mag
... hatte einige Beispiele durchgespielt, aber Dein Beispiel überzeugt!
Gruß

329 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige