Live-Forum - Die aktuellen Beiträge
Datum
Titel
17.06.2024 19:56:24
17.06.2024 19:39:46
Anzeige
Archiv - Navigation
788to792
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
788to792
788to792
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Mittelwertberechnung nur bei Zahlen

Mittelwertberechnung nur bei Zahlen
11.08.2006 18:52:02
Peter
Hallo Excelfreunde
kann mir jemand weiterhelfen.
Ich möchte aus einer Spalte mit 31 Bezügen den Mittelwert errechnen.
Dies aber nur von Zahlen und nicht von Argumenten oder Bezügen.
zB A1 bis A31 sind über einen Bezug mit Werten (Zahlen) belegt, wobei A5 , A9 und A30 nur den Bezug aufweisen aber keine Werte.
Da Excel den Mittelwert aus Zahlen, Bezügen und Argumenten errechnet, ist der Mittelwert natürlich falsch.
Wer weiss hier rat.
Peter

12
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Mittelwertberechnung nur bei Zahlen
11.08.2006 19:13:31
Luc:-?
Hallo Peter,
reicht denn für leere Bezüge nicht die mathematische Formel für den Mittelwert Summe/Anzahl der Werte - m.E. verfährt MITTELWERT() genauso oder wie hast du den richtigen Mittelwert herausgefunden?
Gruß Luc :-?
AW: Mittelwertberechnung nur bei Zahlen
11.08.2006 19:38:50
Erich
Hallo Peter,
Excel berechznet den Mittelwert aus bis zu 30 nummerischen Werten, also Zahlen, NICHT aus Bezügen.
Woher eine Zahl kommt, ob sie als Konstante in einer Zelle steht oder Ergebnis einer Formel ist, spielt keine Rolle.
Die Zahl 0 ist auch eine Zahl - und wird natürlich bei der Berechnung des Mittelwerts berücksichtigt.
Zwischen 0 und Nichts ist ein großer Unterschied.
Wenn du eine Zelle nicht einbeziehen willst (etwa weil deren Wert noch fehlt),
dann sollte der Wert der Zelle z. B. ein Text (leerer Text oder "k.A.") sein.
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
Dem ist nichts hinzuzufügen! WENN()! Gruß
11.08.2006 19:44:50
Luc:-?
Luc :-?
AW: Mittelwertberechnung nur bei Zahlen
11.08.2006 20:19:41
Peter
Erst einmal einen Dank für die Antworten.
Aber das hilft mir noch nicht weiter.
Wenn ich zB den Mittelwert (Zelle B6) aus den Zellen (D6 bis R6) errechnen möchte, dann soll nur der Mittelwert aus den Ganzzahlen berechnet werden.
Also 8 + 66 ergibt keinen Mittelwert von 5 sondern 37.
Bei meiner Mittelwertberechnung werden aber alle Zellen als Anzahl (auch 0)bei der Berechnung berücksichtigt.
Zur Erklärung diese Datei hat eine Eingabemaske aus der mehrer Diagramme erstellt werden.
Aus der Eingabedatei werden Stückzahlen als Zahl und in ppm(part per milion) ausgegeben.
Wichtig hierbei ist der Vergleich Mittelwert "Laufender Monat" zum Mittelwert des letzten Quartals.
Aber ohne richtigen Mittelswert nützt mir die Paretoanalyse nichts.
Über eine Lösung würde ich mich sehr freuen, da ich hier einige Tage dran verzweifele.
Anzeige
AW: Mittelwertberechnung nur bei Zahlen
Orakel
Wie wärs z.B. mit Formel
=WENN(SUMME('C:\Philips 2006\Dieter\Analysen original\Versuch Original 6-2006\Ausfall 2006\7621\[Versuch.xls]Tägliche Hauptfehler'!B3)&gt0;'C:\Philips 2006\Dieter\Analysen original\Versuch Original 6-2006\Ausfall 2006\7621\[Versuch.xls]Tägliche Hauptfehler'!B3;"")
in Zelle D6 usw.
Gruß, Orakel
AW: Mittelwertberechnung nur bei Zahlen
11.08.2006 20:39:28
Josef
Hallo Peter!
Vielleicht hilft dir das.
Tabelle1
 ABCD
138 24,2532,3333333
2    
39   
40   
542   
60   
734   
8    
965   
106   
Formeln der Tabelle
C1 : =MITTELWERT(A1:A10)
D1 : {=MITTELWERT(WENN(A1:A10<>0;A1:A10))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Sepp
Anzeige
AW: Mittelwertberechnung nur bei Zahlen
11.08.2006 21:08:13
Peter
Danke euch für die Hilfe
Diese scheint die Lösung für mich zu sein.
(=MITTELWERT(WENN(E6:S60;E6:S6))
Aber jetzt wird bei fehlenden Werten #DIV/0! angezeigt. Hier braucht nichts angezeigt zu werden.
Aber ich denke auch das kann noch gelöst werden
Siehe auch
https://www.herber.de/bbs/user/35739.xls
Peter
AW: Mittelwertberechnung nur bei Zahlen
11.08.2006 22:03:15
Josef
Hallo Peter!
Tabelle1
 B
1Mittelwert
laufender
Monat
2
3
4
57,50
Formeln der Tabelle
B5 : {=WENN(SUMME(D5:R5)<>0;MITTELWERT(WENN(D5:R5<>0;D5:R5));0)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Sepp
Anzeige
AW: Mittelwertberechnung nur bei Zahlen
11.08.2006 22:31:43
Peter
Hallo Josef
ich danke dir.
Du bist der King
Ich werfe mich vor dir in den Staub oh du mein Retter und mein neuer Excelguru.
Peter voller demut
So ein Salm! Mit etwas Nachdenken über...
13.08.2006 21:33:17
Luc:-?
...Erichs Antwort wärst du selbst auf eine praktikable Lösung gekommen, Peter.
Aber wahrscheinlich bist du einer, der den Wald vor lauter Bäumen nicht sieht. ;-)
Gruß Luc :-?
AW: Mittelwertberechnung nur bei Zahlen
11.08.2006 20:48:52
Josef
Hallo Peter
Ich nehme an, dass keine Minuswerte vorkommen.
Dann kannst du das so machen:
=SUMME(D5:R5)/ZÄHLENWENN(D5:R5;"&gt0")
Gruss Josef

305 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige