nichtleere Datensätze versch. Spalten zählen

Bild

Betrifft: nichtleere Datensätze versch. Spalten zählen
von: Albrecht Benzing
Geschrieben am: 16.11.2015 17:11:41

Hallo zusammen,
meine Frage ist sicher ziemlich trivial, aber ich steh auf dem Schlauch:
Die Datensätze stehen in A1:D10
Ich will zählen, wie viele Datensätze sowohl in A einen Eintrag haben, als auch ENTWEDER in C ODER in D. Ich habe es mit

=SUMMENPRODUKT((A1:A10<>"")*(ODER(C1:C10<>"";D1:D10<>"")))
versucht. Die Formel funktioniert bei diesem einfachen Beispiel auch, aber bei einer komplexeren Tabelle versagt sie aus irgendeinem Grund. Ich vermute aber, ich denke viel zu kompliziert, und man könnte das viel einfacher hinkriegen.
Vielen Dank für eure bewährte Hilfe!
Albrecht

Bild

Betrifft: AW: nichtleere Datensätze versch. Spalten zählen
von: Albrecht Benzing
Geschrieben am: 16.11.2015 17:23:14
Ich habe gerade gemerkt, dass die Formel auch bei dem einfachen Beispiel nicht funktioniert. Also nicht nur zu kompliziert, sondern auch falsch gedacht...

Bild

Betrifft: AW: z.B. mit SUMMENPRODUKT() und + ...
von: ... neopa C
Geschrieben am: 16.11.2015 17:41:28
Hallo Albrecht,
... so: =SUMMENPRODUKT((A1:A10<>"")*((C1:C10<>"")+(D1:D10<>"")))
Gruß Werner
.. , - ...

Bild

Betrifft: so nicht !
von: WF
Geschrieben am: 16.11.2015 17:50:44
Hi,
es kann auch in C UND D was stehen
=SUMMENPRODUKT(((A1:A10<>"")*((C1:C10<>"")+(D1:D10<>""))>0)*1)
WF

Bild

Betrifft: AW: richtig ...
von: ... neopa C
Geschrieben am: 16.11.2015 18:03:33
Hallo WF,
... das hatte ich übersehen.
Doch ausreichend wäre dann auch


=SUMMENPRODUKT((A1:A10<>"")*(((C1:C10<>"")+(D1:D10<>""))>0)) 
Gruß Werner
.. , - ...

Bild

Betrifft: AW: so nicht !
von: Albrecht Benzing
Geschrieben am: 16.11.2015 18:05:24
Vielen Dank erst mal an euch beide!
Also, leider wieder das Gleiche... bei dem einfachen Beispiel funktioniert die Formel von WF, bei meiner "eigentlichen" Tabelle leider nicht:
https://www.herber.de/bbs/user/101565.xlsx
Dort habe ich die Formel im Blatt Cultivos, in N5 umgesetzt. Sie müsste eigentlich 1 ergeben, ergibt aber 4.
Beste Grüße

Bild

Betrifft: AW: so nicht !
von: SF
Geschrieben am: 16.11.2015 18:09:14
Hola,
liegt es vielleicht an den Überschriften in Zeile 1 und 2 die du mit in die Zählung einbeziehst?
Gruß,
steve1da

Bild

Betrifft: AW: so nicht !
von: SF
Geschrieben am: 16.11.2015 18:09:15
Hola,
liegt es vielleicht an den Überschriften in Zeile 1 und 2 die du mit in die Zählung einbeziehst?
Gruß,
steve1da

Bild

Betrifft: AW: so nicht !
von: Albrecht Benzing
Geschrieben am: 16.11.2015 19:01:17
Ja, das war's natürlich, Danke für den Hinweis!
Aber irgendwas ist trotzdem noch faul, jetzt ist das Ergebnis 2 statt 4 - sollte aber 1 sein! Hier die korrigierte Version:
https://www.herber.de/bbs/user/101567.xlsx

Bild

Betrifft: AW: Du vergleichst nicht die 0-Werte ...
von: ... neopa C
Geschrieben am: 16.11.2015 19:13:46
Hallo Albrecht,
... so:


=SUMMENPRODUKT((Productores!A3:A200<>"")*(((Productores!L3:L200<>0)+(Productores!M3:M200<>0)+
(Productores!N3:N200<>0)+(Productores!O3:O200<>0)+(Productores!P3:P200<>0))>0))

Gruß Werner
.. , - ...

Bild

Betrifft: AW: Du vergleichst nicht die 0-Werte ...
von: Albrecht Benzing
Geschrieben am: 16.11.2015 19:21:41
Jetzt hat's geklappt, herzlichen Dank! (wobei ich nicht ohne das *1 am Schluss auskomme, sonst erscheint leer, aber macht ja nix...)

Bild

Betrifft: AW: richtige Klammersetzung vornehmen ...
von: ... neopa C
Geschrieben am: 16.11.2015 19:27:15
Hallo Albrecht,
... dann brauchst Du die *1 nicht. Mit meiner Formel ist das gewährleistet.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: richtige Klammersetzung vornehmen ...
von: Albrecht Benzing
Geschrieben am: 16.11.2015 21:53:40
Stimmt, Danke!

Bild

Betrifft: Deine Fmln in 'Productores' erzeugen eine ...
von: Luc:-?
Geschrieben am: 16.11.2015 20:09:08
…nicht angezeigte 0, Albrecht,
wie dir ja Werner inzwischen mitgeteilt hat. Mir ist deine inzwischen erweiterte Fml aber viel zu umständlich, weshalb ich Folgendes vorschlage:
1. Cultivos!N5 auswählen und folgd Namen definieren:
Betreff: HectareasLP
Bezug: =AUSWERTEN(WECHSELN("summe(--(Productores!L#:P#>0))";"#";AUSWERTEN("zeile(A3:A200)")))
(Für die dt Fktsnamen, auch summe und zeile, die entsprd Namen deiner lokalen Xl-Version einsetzen!)
2. Dann folgd ZellFml eintragen:
N5: =SUMMENPRODUKT((Productores!A3:A200<>"")*(HectareasLP>0))
Gruß, Luc :-?

Besser informiert mit …

Bild

Betrifft: AW: Deine Fmln in 'Productores' erzeugen eine ...
von: Albrecht Benzing
Geschrieben am: 16.11.2015 21:52:53
Hallo Luc,
ich hab's ausprobiert, und es funktioniert tadellos! Ich muss aber gestehen, dass ich hier nur sehr begrenzt kapiere, was eigentlich funktioniert, weil vor allem der "Bezug" zu hoch ist für mich.
Trotzdem vielen Dank!
Albrecht

Bild

Betrifft: Erläuterung
von: Luc:-?
Geschrieben am: 17.11.2015 03:17:11
Morrn, Albrecht;
die benannte Fml kann auf diese Weise leicht um weitere Spalten erweitert wdn, ohne dass man den Weg über die Einzel­Addition der Spalten gehen muss. In der Fml wird 2× die alte XLM*-Fkt AUSWERTEN verwendet, mit der als Text notierte Fmln ausgewertet, d.h. berechnet wdn können.
Das Auswerten von zeile liefert einen ganzen Vektor von ZeilenNrn, auch bei nur einer FmlZelle wie hier (sonst wäre es nur eine Nr, die pro Zelle variiert würde). WECHSELN dagegen fktioniert recht normal und setzt alle diese Nrn nacheinander in den FmlText ein. Das Auswerten von summe sorgt dann dafür, dass auch alle so entstehenden Zeilen­Summen als ein Vektor ausgegeben wdn, was sonst nicht der Fall wäre. Hinzu kommt, dass bei benannten Fmln stets alle Werte berechnet wdn, nur, was letztlich in einer Zelle ausgegeben wird, hängt von der Form der benannten Fml, dito der der ZellFml und alternativ (bei mehrzelligen MatrixFmln) der jeweiligen Zelle ab.
In der ZellFml sorgt SUMMENPRODUKT dafür, dass nicht nur das ganze Ergebnis­Datenfeld für A3:200, sondern auch das ganze, unter dem Namen erzeugte Datenfeld gleicher (sonst gäb's einen Fehler) Werte­Anzahl verwendet wird → was man gut erkennen kann, wenn man diese FmlVariante im FmlAssi betrachtet: =SUMMENPRODUKT(--(Productores!A3:A200<>"");--(HectareasLP>0))
* Excel4-Makro — kein VBA-Pgm, sondern in der alten, bis Xl-Version 4 angewendeten MakroSprache geschrieben, weshalb eine diese verwendende Datei als .xlsm/b gespeichert wdn muss; nur in benannten Fmln anwendbar und mit vbFkt Evaluate, die allerdings FmlTexte in US-Original-Notation erfordert, vglbar.
Gruß, Luc :-?

Bild

Betrifft: AW: Wichtiges steht im Kleingedruckten ;-) ...
von: ... neopa C
Geschrieben am: 17.11.2015 08:21:30
Hallo Luc,
... das die Datei bei Anwendung einer Excel4-Makro Funktion als .xlsm/b gespeichert werden muss, ist Dir wie mir und einigen natürlich klar, aber anderen womöglich noch nicht. Deshalb hier nochmal der Hinweis, weil manche (Dein) Kleingedrucktes nicht lesen.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "nichtleere Datensätze versch. Spalten zählen"