Excel kopiert nicht korrekt

Bild

Betrifft: Excel kopiert nicht korrekt
von: Runow
Geschrieben am: 16.11.2015 17:41:10

Hallo,
ich wollte eine Handy-Nummer aus einer Liste meines Routers Fritz-Box in eine Zelle einer Excel-Tabelle kopieren. Leider wurde beim Kopieren die führende Null der Handynummer nicht mit in die Zelle kopiert, während dies bei Word 2013 einwandfrei funktioniert hat. Woran kann es liegen, dass Excel die Null nicht mit übernimmt?
Gruß Runow

Bild

Betrifft: AW: Excel ist nicht Word und umgekehrt ...
von: ... neopa C
Geschrieben am: 16.11.2015 17:46:38
Hallo Runnow,
... von Haus aus arbeitet Excel vordergründig mit Zahlenwerten und Wort mit Textwerten.
Beide können aber auch das jeweils andere.
Aber dann muss man Excel das auch "mitteilen". Es gibt da z.B. die Möglichkeit mit benutzerdefinierten Zahlenformat zu arbeiten oder die Ziffernfolge als Text zu formatieren. Im beiden Fällen können dann natürlich auch führende 0en mit dargestellt werden.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: zu Benutzerdefiniertes Zellformat sieh mal ...
von: ... neopa C
Geschrieben am: 16.11.2015 17:49:32
Hallo,
... hier http://www.online-excel.de/excel/singsel.php?f=71
Den richtigen Umgang mit Textformat setze ich bei Excel:gut voraus.
Gruß Werner
.. , - ...


Bild

Betrifft: AW: zu Benutzerdefiniertes Zellformat sieh mal ...
von: Runow
Geschrieben am: 16.11.2015 18:16:56
Hallo, Werner,
die Zellen, in die die Handynummer kopiert werden sollte, waren im Textformat formatiert.
Gruß Runow

Bild

Betrifft: AW: Ziffernfolgen im Textformat ...
von: ... neopa C
Geschrieben am: 16.11.2015 19:24:42
Hallo Runnow,
... dabei werden führende 0en auch also solche dargestellt.
Es sei denn, Du wandelst durch das Kopieren das Zellformat wieder in Zahlenformat. Das passiert bei Werten die reine Ziffernfolgen sind durch Excel automatisch (schließlich ist Excel ein Kalkulationsprogramm!)
Wenn Du das verhindern willst, musst Du also beim Einspielen/einkopieren solcher Ziffernfolgen immer nur die Funktion: Werte einkopieren nutzen.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: zu Benutzerdefiniertes Zellformat sieh mal ...
von: Runow
Geschrieben am: 16.11.2015 23:24:12
Hallo, Werner,
natürlich kann ich eine Zelle für führende Nullen formatieren, aber das hilft mir nicht wirklich. Denn die Telefonnummern haben unterschiedliche Längen, und Excel würde in diesem Fall bei genügend vielen vorgegebenen Stellen mehr als eine Null voranstellen.
Gruß Runow

Bild

Betrifft: Dann setze ein TextPräfix (') vor d.volle TNr! orT
von: Luc:-?
Geschrieben am: 17.11.2015 03:28:30
Gruß, Luc :-?

Besser informiert mit …

Bild

Betrifft: AW: Dann setze ein TextPräfix (') vor d.volle TNr! orT
von: Runow
Geschrieben am: 17.11.2015 09:00:24
Hallo, Luc,
wenn ich das Textzeichen "'" vor die Telefonnummer setze, erscheint die führende Null trotzdem nicht.
Gruß Runow

Bild

Betrifft: Das solltest du nicht nachträglich machen, ...
von: Luc:-?
Geschrieben am: 17.11.2015 13:20:24
…Runow,
sondern schon im Original, bevor du das in Xl einkopierst/importierst! Alternativ könntest du auch die Vorwahl mit - von der eigentlichen TNr trennen, dann dürfte die von Xl idR auch immer als Text angesehen wdn.
Luc :-?

Bild

Betrifft: AW: Das solltest du nicht nachträglich machen, ...
von: Runow
Geschrieben am: 17.11.2015 15:45:38
Hallo, Luc,
wie soll ich im Original in der Online-Fritzbox-Liste ein "'" vor die Telefonnummer setzen?
Wenn ich im Excel die Vorwahl durch ein Minuszeichen von der eigentlichen Telefonnummer trenne, erscheint dennoch die führende Null nicht.
Gruß Runow

Bild

Betrifft: Letzteres aber bei mir, ansonsten s.neopa ...
von: Luc:-?
Geschrieben am: 17.11.2015 15:57:28
…und mal 'n bissken die Möglichkeiten durchprobieren, Runow,
evtl auch in TextDatei zwischennotieren. Kann doch nicht so schwer sein…
Luc :-?

Bild

Betrifft: AW: Letzteres aber bei mir, ansonsten s.neopa ...
von: Runow
Geschrieben am: 17.11.2015 16:14:13
Hallo, Luc,
wenn ich etliche Zwischenarbeit leisten muss, bevor mir die führende Null angezeigt wird, kann ich gleich der falsch eingefügten Nummer per Hand eine Null voranstellen und habe die "Lösung". Das war aber nicht der Sinn meiner Anfrage. Vielmehr scheint ein Fehler bei meinem Excel vorzuliegen, das die Inhalte der Zwischenablage nicht korrekt übernimmt.
Gruß Runow

Bild

Betrifft: AW: offensichtlich hast Du überlesen ...
von: ... neopa C
Geschrieben am: 17.11.2015 14:03:29
Hallo Runow,
... oder evtl. nicht verstanden, was ich Dir ein paar Stunden zuvor geschrieben hatte:
"... beim Einspielen/einkopieren solcher Ziffernfolgen immer nur die Funktion: Werte einkopieren nutzen..." wenn Du diese Werte (mit vorangestellter 0) in Text formatierte Zellen übernimmst.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: offensichtlich hast Du überlesen ...
von: Runow
Geschrieben am: 17.11.2015 16:09:24
Hallo, Werner,
Excel bietet mir in diesem Fall die Option "Werte einfügen" gar nicht an. Wenn ich auf "Inhalte einfügen" klicke, bietet mir Excel die Optionen "Einfügen als HTML oder als Unicode-Text oder als Text" an; in jedem dieser Fälle wird die führende Null nicht angezeigt. Sie wird übrigens selbst dann nicht angezeigt, wenn ich die Nummer zunächst in WORD kopiere (wo sie korrekt angezeigt wird) und von dort nach Excel kopiere. In diesem Fall kommen bei "Inhalte einfügen" lediglich zu den oben genannten drei Optionen die Wahlmöglichkeiten "Microsoft Word-Dokument-Objekt" und "Bild (Erweiterte Metadatei" hinzu.
Gruß Runow

Bild

Betrifft: AW: doch das tut Excel ...
von: ... neopa C
Geschrieben am: 17.11.2015 16:37:52
Hallo Runow,
... zum Einfügen rechte Maustaste aktivieren und dort die Option "An Zellformatierung anpassen(M)" wählen.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: doch das tut Excel ...
von: Runow
Geschrieben am: 17.11.2015 17:12:56
Hallo, Werner,
jetzt funktioniert es. Ich habe nun die gesamte Spalte mit den Telefonnummern im Textformat formatiert und dann die Einfügeoption "An Zielformatierung anpassen (M)" gewählt, und damit erscheint auch die führende Null.
Besten Dank Runow

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Excel kopiert nicht korrekt"