Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Nichtleere Zellen zählen
01.08.2008 15:03:00
Mike
Hallo,
stehe gerade etwas auf dem Schlauch!
Wie ermittel ich die Anzahl der nichtleeren Zellen um für den Mai das Ergebnis 20 zu bekommen?
Die Werte in der Spalte B in der Tab1 werden per Formel eingelesen!
In der Tab2 werte ich die Daten per Formel aus der Tab1 aus. Aber wie?
Danke vorab und Gruß
Mike
Tab1 A B
1 Mai 30
2 Mai
3 Mai 10
4 Jun 30
5 Jun 20
6 Jun 40
Tab2 A B
1 Mai =Summe Mai aus Tab1 Spalte B / Anzahl Mai aus Tab1 Spalte B
2 Jun =Summe Jun aus Tab1 Spalte B / Anzahl Mai aus Tab1 Spalte B
Ergebnis
Mai 20 (30+10)/3
Jun 30 (30+20+40)/3

10
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Nichtleere Zellen zählen
01.08.2008 15:27:33
David
z. Bsp. so:
Tabellenblattname: Tabelle2
 

A

B

C

D

E

1

Mai

30

 

Mai

20

2

Mai

 

 

Jun

30

3

Mai

10

 

 

 

4

Jun

30

 

 

 

5

Jun

20

 

 

 

6

Jun

40

 

 

 


Benutzte Formeln:
E1: =SUMMEWENN(A1:A6;D1;B1:B6)/SUMMENPRODUKT((A1:A6=D1)*(B1:B6""))
E2: =SUMMEWENN(A1:A6;D2;B1:B6)/SUMMENPRODUKT((A1:A6=D2)*(B1:B6""))
Dein Vorlagebeispiel ist übrigens falsch. Laut deiner Erklärung wäre für Mai (30+10)/2. Deine Rechnung würde 13,33 ergeben.
Gruß
David

Anzeige
AW: Nichtleere Zellen zählen
01.08.2008 15:35:07
Mike
Danke und schönes Wochenende
Mike

AW: Nichtleere Zellen zählen
01.08.2008 15:28:38
mpb
Hallo Mike,
das Ergebnis 20 für den Mai (=Mittelwert für die vorhandenen Werte im Mai) erhältst Du z.B. so:
=SUMMENPRODUKT((A1:A6="Mai")*(B1:B6))/SUMMENPRODUKT((A1:A6="Mai")*(LÄNGE(B1:B6)>0))
Gruß
Martin

AW: Nichtleere Zellen zählen
01.08.2008 15:35:00
Mike
Danke und schönes Wochenende
Mike

AW: Nichtleere Zellen zählen
01.08.2008 15:29:15
Ramses
Hallo
Tabelle3

 AB
1Mai30
2Mai 
3Mai10
4Jun30
5Jun20
6Jun40
7  
8  
9  
10Ergebnis 
11Mai13.33333333
12Jun30

Formeln der Tabelle
ZelleFormel
B11=SUMMENPRODUKT((($A$1:$A$6)=A11)*($B$1:$B$6))/ZÄHLENWENN(A1:A6;A11)
B12=SUMMENPRODUKT((($A$1:$A$6)=A12)*($B$1:$B$6))/ZÄHLENWENN(A2:A7;A12)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruss Rainer

Anzeige
AW: Nichtleere Zellen zählen
01.08.2008 15:35:00
Mike
Danke und schönes Wochenende
Mike

AW: Nichtleere Zellen zählen
01.08.2008 15:35:00
David
Du berücksichtigst nicht, daß der Mai nur 2 Werte hat, die gezählt werden sollen (Ergebnis = 20).
Dann ginge die Formel auch kürzer, z. Bsp. so:
=SUMMEWENN(A1:A6;"Mai";B1:B6)/ZÄHLENWENN(A1:A6;"Mai")
Gruß
PS: Bitte nicht hauen! Excel gut? ;-)

AW: Nichtleere Zellen zählen
01.08.2008 15:42:08
Ramses
Hallo
Die Frage lautete:
"...1 Mai =Summe Mai aus Tab1 Spalte B / Anzahl Mai aus Tab1 Spalte B .."
Da steht nichts davon, dass im Mai ein Wert vorhanden sein muss.
Daher rechnet die Formel nach Anfoderung korrekt
Es gibt viele Wege nach Rom, und ich habe keine Lust an Formelwettbewerben um Verkürzungen teilzunehmen.
SUMMEWENN ist auf grösseren Datenbereichen nach meinen Erfahrungen deutlich langsamer als Summenprodukt.
Aber egal ...
Gruss Rainer

Anzeige
AW: Nichtleere Zellen zählen
01.08.2008 15:50:00
mpb
Hallo Rainer,
Mike schrieb am Anfang aber auch:
"Wie ermittel ich die Anzahl der nichtleeren Zellen um für den Mai das Ergebnis 20 zu bekommen?"
Zugegeben, nicht gerade die präziseste Frageformulierung, aber daraus lässt sich m.E. schon schließen, dass er den Mittelwert für den Mai ohne die leeren Zellen sucht, das Ergebnis also 20 sein soll. Entsprechend habe ich meinen Formelvorschlag konstruiert. Interessant ist, das Mike allen 3 Antwortern gedankt hat, obwohl die Formeln unterschiedliche Ergebnisse liefern. ;-)
Gruß
Martin

AW: Nichtleere Zellen zählen
01.08.2008 15:50:59
David
Die Frage lautete:
Wie ermittel ich die Anzahl der nichtleeren Zellen um für den Mai das Ergebnis 20 zu bekommen?
Außerdem weiter:
Ergebnis
Mai 20 (30+10)/3

(ich werte das vorgegebene Ergebnis von 20 höher als den Formelfehler /3 statt /2)
Genau: Aber egal...
Ich will mich auch nicht streiten. Ich wollte dir damit nur zeigen, dass ich durchaus in der Lage bin, über Formeln nachzudenken und welche zu erstellen. Und jetzt wirklich Schluss...
nix für ungut.
Gruß und schönes Wochenende, ich mache jetzt Feierabend.
David
Anzeige

333 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige