Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summewenns mit leeren Zellen

Summewenns mit leeren Zellen
05.10.2022 16:39:21
Sebastian
Hallo Profis,
ich habe eine Tabelle hier wird die Summe erstellt wenn einige Kreterien erfüllt sind.
In A1 steht das Anfangsdatum und in A2 das Enddatum
A4 = SUMMEWENNS(Tabelle1!$L$11:$L$5000;Tabelle1!$Q$11:$Q$5000;"="&"";Tabelle1!$A$11:$B$5000;">="&$A1;Tabelle1!$B$11:$B$5000;" in der Spalte Q steht aber ein Sverweis, der dann als Ergebiss wenn falsch "" einträgt.
Scheinbar funktioniert Tabelle1!$Q$11:$Q$5000;"="&"" nicht. Hat jemand eine Idee wie ich die leeren Zeilen zählen kann?
Vielen Dank und viele Grüße
marspoki

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Summewenns mit leeren Zellen
05.10.2022 16:45:05
{Boris}
Hi,
= SUMMEWENNS(Tabelle1!$L$11:$L$5000;Tabelle1!$Q$11:$Q$5000;"";Tabelle1!$A$11:$A$5000;">="&$A1; Tabelle1!$B$11:$B$5000;" Tabelle1!$A$11:$B$5000 hab ich zudem auf Tabelle1!$A$11:$A$5000 geändert.
VG, Boris
AW: Summewenns mit leeren Zellen
05.10.2022 17:27:51
Sebastian
Das klappt
= SUMMEWENNS(Tabelle1!$L$11:$L$5000;Tabelle1!$Q$11:$Q$5000;"";Tabelle1!$A$11:$A$5000;">="&$A1; Tabelle1!$B$11:$B$5000;" Nur noch eine Frage, wie klann ich summieren wenn die Zeilen nicht "" sind?
= SUMMEWENNS(Tabelle1!$L$11:$L$5000;Tabelle1!$Q$11:$Q$5000;""&"";Tabelle1!$A$11:$A$5000; ">="&$A1; Tabelle1!$B$11:$B$5000;" das geht leider nicht :-(
Anzeige
AW: Summewenns mit leeren Zellen
05.10.2022 17:48:07
GerdL
;""; ohne &""
AW: Summewenns mit leeren Zellen
05.10.2022 17:48:25
Daniel
Hi
wenn die Rückgabewerte Texte sind, kannst du alle Texte außer "" hiermit auswerten: "?*"
dh mindesten ein Zeilchen "?" und danach beliebig viele anderen Zeilen (auch keines)
btw, das &"" bringt dir hier nichts. Einen Leerstring an einen anderen String anhängen hat keinen Effekt.
Gruß Daniel
AW: Summewenns mit leeren Zellen
05.10.2022 17:53:11
Sebastian
Das Fragezeichen ist die Lösung :-) "?"
Vielen Vielen Dank - da muss man erstmal drauf kommen :-)
AW: Summewenns mit leeren Zellen
05.10.2022 17:53:37
Sebastian
Frage natürlich erledigt -
Danke an euch beide :-)
AW: Summewenns mit leeren Zellen
05.10.2022 17:44:06
Daniel
Hi
der Vergleichswert "=" ermittelt nur echte Leerzellen.
Zellen die Formeln enthalten, werden nicht berücksichtigt, egal wie das Formelergebnis ist. auch der Ausgabewert "" ist ein Text.
und "="&"" ist übrigens genau das gleiche wie "="
Der Vergleichswert "" ermittelt echte Leerzellen und Formeln mit dem Text "" als Ergebnis.
Wenn man jetzt differnzieren will zwischen echten Leerzellen und Formelergebnis "", dh man will nur die Zellen mit Formelergebnis "" aber keine echten Leerzellen (warum auch immer), müsste man einen zusätzlichen vergleich anstellen, aber in eine ordentlichen Tabelle sollten in einer Spalte mit Formeln keine Leerzellen zwischendrin vorkommen.

...;Tabelle1!$Q$11:$Q$5000;"";Tabelle1!$Q$11:$Q$5000;"";...
Gruß Daniel
Anzeige

347 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige