Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zeilennummer wenn wert ungleich 0

Zeilennummer wenn wert ungleich 0
18.02.2019 13:58:33
Cindy
Hallo zusammen,
ich habe mal wieder ein Problem. Ich suche alle Zeilennummern aus Spalte A, wo der Wert nicht Null ist. Ergebnisse sollen in anderer Spalte z.B. C angezeigt werden
Wenn möglich suche ich eine Formellösung.
Vielen Dank
Userbild

10
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zeilennummer wenn wert ungleich 0
18.02.2019 14:01:28
Matthias
Hi
Tabelle1

 ABC
40  
50  
62000 6

Formeln der Tabelle
ZelleFormel
C4=WENN(A4<>0;ZEILE();"")
C5=WENN(A5<>0;ZEILE();"")
C6=WENN(A6<>0;ZEILE();"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Excel gut?
Gruß Matthias
Anzeige
AW: Zeilennummer wenn wert ungleich 0
18.02.2019 14:03:23
Georg
Hallo Cindy
z. B. so:
=WENN(A40;ZEILE(A4);"")
und dann nach unten ziehen Gruß Georg
AW: Zeilennummer wenn wert ungleich 0
18.02.2019 20:25:57
Cindy
Hallo,
Danke schon mal,
aber ich hätte gerne keine leer Zeilen in der Spalte C.
LG Cindy
dann schreib statt "" irgendwas rein.
18.02.2019 21:23:17
Matthias
Hi
Du solltet echt Dein Level überdenken.
Gruß Matthias
zum Verstehen ...
18.02.2019 21:36:20
Matthias
Hi
Tabelle1

 ABC
4100 4
50 nix
6101 6
70 nix
80,5 8
9-19,4 9
10-39,3 10
11-59,2 11
12-79,1 12
13-99 13
14-118,9 14
15-138,8 15
16-158,7 16
17-178,6 17
18-198,5 18
19-218,4 19
20-238,3 20
21-258,2 21
22-278,1 22
23-298 23
24-317,9 24
25-337,8 25
26-357,7 26
27-377,6 27
28-397,5 28

Formeln der Tabelle
ZelleFormel
C4=WENN(A4<>0;ZEILE();"nix")
C5=WENN(A5<>0;ZEILE();"nix")
C6=WENN(A6<>0;ZEILE();"nix")
C7=WENN(A7<>0;ZEILE();"nix")
C8=WENN(A8<>0;ZEILE();"nix")
C9=WENN(A9<>0;ZEILE();"nix")
C10=WENN(A10<>0;ZEILE();"nix")
C11=WENN(A11<>0;ZEILE();"nix")
C12=WENN(A12<>0;ZEILE();"nix")
C13=WENN(A13<>0;ZEILE();"nix")
C14=WENN(A14<>0;ZEILE();"nix")
C15=WENN(A15<>0;ZEILE();"nix")
C16=WENN(A16<>0;ZEILE();"nix")
C17=WENN(A17<>0;ZEILE();"nix")
C18=WENN(A18<>0;ZEILE();"nix")
C19=WENN(A19<>0;ZEILE();"nix")
C20=WENN(A20<>0;ZEILE();"nix")
C21=WENN(A21<>0;ZEILE();"nix")
C22=WENN(A22<>0;ZEILE();"nix")
C23=WENN(A23<>0;ZEILE();"nix")
C24=WENN(A24<>0;ZEILE();"nix")
C25=WENN(A25<>0;ZEILE();"nix")
C26=WENN(A26<>0;ZEILE();"nix")
C27=WENN(A27<>0;ZEILE();"nix")
C28=WENN(A28<>0;ZEILE();"nix")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Matthias
Anzeige
AW: Zeilennummer wenn wert ungleich 0
19.02.2019 12:16:07
Daniel
Hi
bspw mit dieser Formel in C4, welche du dann soweit wie benötigt nach unten ziehst:
=WENNFEHLER(AGGREGAT(15;6;ZEILE($A$4:$A$20)/($A$4:$A$200);ZEILE(A1));"")
Gruß Daniel
AW: Zeilennummer wenn wert ungleich 0
20.02.2019 15:55:38
Kulo
Hallo Daniel,
vielen Dank für diese Formel.
Schade, dass sich Cindy nicht mehr gemeldet hat, ob diese Lösung in ihrem Sinne war.
Aber ich habe auch versucht, dieses Ergebnis zu erhalten und denke, dass das ihrer Fragestellung entspricht.
Ich habe auch versucht, mit AGGREGAT und WENNFEHLER etwas zu erreichen. Aber da fehlt es noch hinten und vorne bei mir.
Jedenfalls ist mir der Schritt mit dem Wahrheitswert ins Auge gefallen. Irgendwie einfach genial und genial einfach - wenn man es denn weiß und verinnerlicht hat.
Hier im Forum hab ich schon jede Menge Hilfe erhalten für die ich sehr dankbar bin. Auch Lösungen in denen mit Wahrheitswerten gerechnet wurde. Mit deiner obigen Formal hat es endlich klick gemacht.
Wieder ein Stück weiter ...
Vielen Dank nochmal und
viele Grüße
Kulo
Anzeige
AW: Zeilennummer wenn wert ungleich 0
25.02.2019 09:25:18
Cindy
Hallo zusammen,
entschuldigt die verspätete Antwort.
Die Lösung von Daniel war die gesuchte.
Vielen DAnk
AW: Zeilennummer wenn wert ungleich 0
25.02.2019 09:25:18
Cindy
Hallo zusammen,
entschuldigt die verspätete Antwort.
Die Lösung von Daniel war die gesuchte.
Vielen DAnk
AW: Zeilennummer wenn wert ungleich 0
25.02.2019 09:25:20
Cindy
Hallo zusammen,
entschuldigt die verspätete Antwort.
Die Lösung von Daniel war die gesuchte.
Vielen DAnk

116 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige