Microsoft Excel

Herbers Excel/VBA-Archiv

wenn wert kleine 0 dann | Herbers Excel-Forum


Betrifft: wenn wert kleine 0 dann von: Ralf
Geschrieben am: 20.12.2009 13:56:25

Hallo Ich bin es noch einmal weiß jetzt nicht ob es richtig war einen neuen Beitrag zu eröffnen oder ich in dem alten hätte bleiben sollen es geht auf jeden fall um die gleiche Tabelle aber um eine andere Formel
hier die tabelle
https://www.herber.de/bbs/user/66718.xls

jetz meine Frage
Ist es möglich wenn der wert der Formel z.B in F 18 kleiner 0 ist das die zelle keinen wert hat "" und dann in G 18 kopiert wird also ich habe da schon selber etwas versucht aber ich bekomme den wert in F 18 nicht raus und wenn wert in F 18 raus geht ja auch die Formel in G 18 nicht mehr denke ich
bin da bischen überfordert
also in F 18 sollen die angefallenen Überstunden stehen und überstunden sind ja nun mal keine minusstunden die möchte ich dann wohl gerne in G 18 stehen haben .

hoffe es ist so verständlich

  

Betrifft: AW: wenn wert kleine 0 dann von: Gerd L
Geschrieben am: 20.12.2009 14:46:26

Hallo Ralf,

...... ich weis nicht. :-)

'=WENN(D17=0;"";WENN(E18-(B17<6)*(B17>1)*RegelMoDo-(B17=6)*RegelFr<0;"";E18-(B17<6)*(B17>1)*RegelMoDo-(B17=6)*RegelFr))~f~

~f~'=WENN(F18="";E18-(B17<6)*(B17>1)*RegelMoDo-(B17=6)*RegelFr;)

Gruß
Gerd


  

Betrifft: AW: wenn wert kleine 0 dann von: BoskoBiati
Geschrieben am: 20.12.2009 23:15:49

Hallo,

in F12:

=WENN(ODER(D11=0;(E12-(B11<6)*(B11>1)*RegelMoDo-(B11=6)*RegelFr)<0);"";E12-(B11<6)*(B11>1) *RegelMoDo-(B11=6)*RegelFr) 
in G12
=WENN(ODER(D11=0;(E12-(B11<6)*(B11>1)*RegelMoDo-(B11=6)*RegelFr)>=0);"";E12-(B11<6)*(B11>1) *RegelMoDo-(B11=6)*RegelFr) 
Gruß

Bosko


  

Betrifft: AW: wenn wert kleine 0 dann von: Ralf
Geschrieben am: 21.12.2009 09:44:18

Hallo

das ist noch nicht das was ich suche vielleicht habe ich es auch zu schlecht erklärt ich versuche es noch einmal
Also wenn z.B der wert in 18G kleiner 0 ist soll da nichts erscheinen , also nur werte über 0

vielleicht versteht man es so besser

gruß Ralf


  

Betrifft: AW: wenn wert kleine 0 dann von: ingoG
Geschrieben am: 21.12.2009 10:49:50

Hallo Ralf,

wenn Du das richtige Ergebnis bereits in der Zelle F18 stehen hast, es aber je nach vorzeichen entweder in F18 oder G18 ausgeben möchtest kannst Du folgendermassen vorgehen:

in F18: =wenn('alte Formel'<=0;"";'alteFormel')
in G18: =wenn('alte Formel'>=0;"";'alteFormel')
ich hoffe, das ist es was Du meintest...

Gruß Ingo
PS eine Rückmeldung wäre nett...


  

Betrifft: AW: wenn wert kleine 0 dann von: Ralf
Geschrieben am: 21.12.2009 13:34:09

Hallo und schon mal danke für die hilfe
Also das ieht von der formel schon ganz gut aus soweit ich das beurteilen kann aber wenn ich die formel dort einfüge passt da irgendetwas nicht mitt ( ) = oder so bei so einer formel fehlt mir komplett die Übersicht ich seh nicht mehr wo etwas falsch sein könnte dafür bin ich noch zu frisch in dem Thema drin hier die formel die ich eingefügt habe

in
G 18 =wenn((E17=0;"";F18-(C17<6)*(C17>1)*RegelMoDo-(C17=6)*RegelFr)'<=0;"";'(E17=0;"";F18-(C17<6)*(C17>1)*RegelMoDo-(C17=6)*RegelFr)') ~f~


in~f~
H 18 =wenn(=WENN(G18<=0;F18-(C17<6)*(C17>1)*RegelMoDo-(C17=6)*RegelFr;)'>=0;"";'=WENN(G18<=0;F18-(C17<6)*(C17>1)*RegelMoDo-(C17=6)*RegelFr;)')


oder habe ich das total falsch mit alter formel einfügen


  

Betrifft: AW: wenn wert kleine 0 dann von: ingoG
Geschrieben am: 21.12.2009 16:02:14

Hallo Ralf,

versuchs mal so:



=wenn(wenn(E17=0;"";F18-(C17<6)*(C17>1)*RegelMoDo-(C17=6)*RegelFr)<=0;"";wenn(E17=0;""; F18-(C17<6)*(C17>1)*RegelMoDo-(C17=6)*RegelFr))

und


=wenn(wenn(E17=0;"";F18-(C17<6)*(C17>1)*RegelMoDo-(C17=6)*RegelFr)>=0;"";wenn(E17=0;""; F18-(C17<6)*(C17>1)*RegelMoDo-(C17=6)*RegelFr))


Gruß Ingo
PS eine Rückmeldung wäre nett...


  

Betrifft: AW: wenn wert kleine 0 dann von: Ralf
Geschrieben am: 21.12.2009 16:29:42

Ne das geht auch nicht sorry

Habe es jetzt über einen anderen weg gemacht habe in f 15 die formel stehen und dann wird wenn der wert negativ oder positiv ist er in eine anderen zelle kopiert und dfann blende ich die komplette spalte f nacher aus dann ist das auch OK für mich aber noch mals Danke für deine Mühe

gruß Ralf