Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn-Dann | Herbers Excel-Forum


Betrifft: Wenn-Dann von: Jenny
Geschrieben am: 23.10.2008 10:31:53

Hallo,

also in meiner Tabelle habe ich mehrere Daten z.B. 01.12.1990. Excel soll mir nun alle Daten die vor dem 01.10.2005 waren als 01.10.2005 anzeigen...alle Daten die nach dem 01.10.2005 sind soll er mir auch genau anzeigen. Geht das?

Lieben Gruß

  

Betrifft: AW: Wenn-Dann von: ANdreas
Geschrieben am: 23.10.2008 10:39:37

Hallo Jenny,

man kann ein Makro schreiben und die Werte ersetzen oder ohne VBA mit Hilfsspalte.
Datumswerte in Spalte A, Hilfsspalte in B mit folgender Formel:

=WENN(A1="";"";WENN(A1<DATUM(2005;10;1);DATUM(2005;10;1);A1))

Falls die Originärwerte nicht mehr benötigt werden, kann man die Hilfsspalte einfach kopieren, Inhalte einfügen... Werte. Die Spalte A kann danach weg.

Gruß
Andreas


  

Betrifft: AW: Wenn-Dann von: Born
Geschrieben am: 23.10.2008 10:40:06

Hi,
trage als Formel in die Zelle ein: =WENN(B27>38626;38626;B27)
wobei B27 durch die Zelle ersetzt werden muss, die Du abgleichen willst.

Gruß,
M. Born


  

Betrifft: AW: Wenn-Dann von: David
Geschrieben am: 23.10.2008 10:43:12

Hallo M.

Dein Operator ist verkehr herum! < statt >

Gruß
David


  

Betrifft: AW: Wenn-Dann von: Born
Geschrieben am: 23.10.2008 10:45:13

Oops. Aber die Richtung war erkennbar, hoffe ich.


  

Betrifft: AW: Wenn-Dann von: David
Geschrieben am: 23.10.2008 10:41:42

Hallo Jenny,

=WENN(A1<38626;38626;A1)

und als Datum formatieren.
Anschließend soweit wie nötig kopieren. (Wenn Ursprungsdatum nicht in Spalte A, dann anpassen.)

Gruß
David


  

Betrifft: AW: Wenn-Dann von: Jenny
Geschrieben am: 23.10.2008 10:42:54

Super, vielen DANK!!! :o)