1-0 Tabelle | Wert vorhanden dann 1, sonst 0

Bild

Betrifft: 1-0 Tabelle | Wert vorhanden dann 1, sonst 0
von: Pascal
Geschrieben am: 23.02.2005 17:15:18
Hallo Exelperten,
ich versuche gerade eine elegante Lösung für folgendes Problem zu finden:
In Tabelle A habe ich:
nummern und Texte
100 bsp1
100 bsp2
102 bsp1
103 bsp4
etc.
In Tabelle B habe ich links wieder Nummern und die bsp1 bis bspn als Spaltenüberschriften. Wie bekomme ich hin, dass B wie folgt gefüllt wird?
_____bsp1____bsp2___bsp3____bsp4
100____1______1
101
102____1
103___________________________1
Gibt es für so etwas Matrixformeln. (Für mich immer noch ein Buch mit sieben Siegeln!) Mit sVerweis bin ich nicht weiter gekommen. Werde mich jetzt mal an VB trauen.
Gruß und Danke für jede Idee hierzu!
Pascal

Bild

Betrifft: AW: 1-0 Tabelle | Wert vorhanden dann 1, sonst 0
von: M. Gottschalk
Geschrieben am: 23.02.2005 17:21:02
Probier doch mal die daten zu trennen mit =rechts(A1;2) und füge sie dann wieder mit =Verketten(A2;A3;usw.) zusammen
Bild

Betrifft: AW: 1-0 Tabelle | Wert vorhanden dann 1, sonst 0
von: Galenzo
Geschrieben am: 23.02.2005 17:21:08
Annahmen:
Spalte A: Zahlen 100....
Spalte B: Text
Spalte C (ab C1) - Zahlen aus Spalte A (ohne Duplikate) - kriegst du mit "Daten/Filter/Spezialfilter" hin)
Zeile 1 (ab D1) nebeneinander die "vergebenen" Texte
die Formel ist dann (hier für Zelle D2)
=SUMMENPRODUKT(($B$1:$B$5=D$1)*($A$1:$A$5=$C2))
Runter- und rüberkopieren - fertig
Bild

Betrifft: AW: 1-0 Tabelle | Wert vorhanden dann 1, sonst 0
von: HermannZ
Geschrieben am: 23.02.2005 18:03:45
Hallo Pascal,
ein Beispiel;
Summe
 ABCDEF
2093      
2094100 bsp1 bsp1bsp2bsp3bsp4
2095100 bsp21001100
2096102 bsp11010000
2097103 bsp41021000
2098 1030001
2099 1040000
2100      
Formeln der Tabelle
C2095 : {=SUMME(($A$2094:$A$2097=B2095&" "&$C$2094)*1)}
D2095 : {=SUMME(($A$2094:$A$2097=B2095&" "&$D$2094)*1)}
E2095 : {=SUMME(($A$2094:$A$2097=B2095&" "&$E$2094)*1)}
F2095 : {=SUMME(($A$2094:$A$2097=B2095&" "&$F$2094)*1)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß hermann
Bild

Betrifft: DANKE!!! SUPERSACHE DAS!
von: Pascal
Geschrieben am: 23.02.2005 18:16:43
Das funktioniert prima.
Vielen Dank!
Beste Grüße,
Pascal
Bild

Betrifft: AW: Danke für die Rückantwort. oT.
von: HermannZ
Geschrieben am: 23.02.2005 18:42:20
.
Bild

Betrifft: AW: =ZÄHLENWENN($A:$A;$C2&" "&D$1)
von: FP
Geschrieben am: 23.02.2005 20:35:10
Hi Pascal,
ich würde es damit machen:
Tabelle1
 ABCDEFG
1   bsp1bsp2bsp3bsp4
2100 bsp1 10011  
3100 bsp2 101    
4102 bsp1 1021   
5103 bsp4 103   1
Formeln der Tabelle
D2 : =ZÄHLENWENN($A:$A;$C2&" "&D$1)
E2 : =ZÄHLENWENN($A:$A;$C2&" "&E$1)
F2 : =ZÄHLENWENN($A:$A;$C2&" "&F$1)
G2 : =ZÄHLENWENN($A:$A;$C2&" "&G$1)
D3 : =ZÄHLENWENN($A:$A;$C3&" "&D$1)
E3 : =ZÄHLENWENN($A:$A;$C3&" "&E$1)
F3 : =ZÄHLENWENN($A:$A;$C3&" "&F$1)
G3 : =ZÄHLENWENN($A:$A;$C3&" "&G$1)
D4 : =ZÄHLENWENN($A:$A;$C4&" "&D$1)
E4 : =ZÄHLENWENN($A:$A;$C4&" "&E$1)
F4 : =ZÄHLENWENN($A:$A;$C4&" "&F$1)
G4 : =ZÄHLENWENN($A:$A;$C4&" "&G$1)
D5 : =ZÄHLENWENN($A:$A;$C5&" "&D$1)
E5 : =ZÄHLENWENN($A:$A;$C5&" "&E$1)
F5 : =ZÄHLENWENN($A:$A;$C5&" "&F$1)
G5 : =ZÄHLENWENN($A:$A;$C5&" "&G$1)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Servus aus dem Salzkammergut
Franz
Bild

Betrifft: AW: @ FP
von: HermannZ
Geschrieben am: 24.02.2005 11:27:09
Hallo FP,
ist ja fein,aber ist mit der Fragestellung wohl kaum identisch, die Frage war;
---Wert vorhanden dann 1, sonst 0--- oder??
Gruß hermann
Bild

Betrifft: AW: @ FP
von: FP
Geschrieben am: 24.02.2005 21:00:30
Hi Hermann,
die Nullen lasse ich nur einfach nicht anzeigen ;-)
Servus aus dem Salzkammergut
Franz
 Bild

Beiträge aus den Excel-Beispielen zum Thema "1-0 Tabelle | Wert vorhanden dann 1, sonst 0"