Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Spaltenvergleich, dann Wert (WENN bzw. SVERWEIS?)

Spaltenvergleich, dann Wert (WENN bzw. SVERWEIS?)
Ludwig
Hallo!
Ich habe in einer Excel-Datei 2 Reiter.
Im ersten Reiter gibt es eine Spalte mit Personalnummern (in G2), die hier mehrmals auftauchen.
Im anderen Reiter (Pers_Kostl) gibt es in der Spalte A diese Personalnummern auch, jedoch immer nur 1x und in Spalte B die zugehörige Stammkostenstelle.
Leider bekomme ich es nicht hin, das im ersten Reiter, in einer neuen Spalte neben den Personalnummern einen Vergleich gemacht wird mit den Personalnummern aus dem 2. Reiter und dann die Stammkostenstelle aus dem 2. Reiter eintgetragen wird.
Folgendes habe ich schon versucht, allerdings mit Bezugsfehler:
=WENN(ISTNV(SVERWEIS(G2;Pers_Kostl!A2:A245;Pers_Kostl!B2:B245;0));"";SVERWEIS(G2;Pers_Kostl!A2:A245; Pers_Kostl!B2:B245;0))
Ich wäre für Hilfe sehr dankbar.
Gruß,
Ludwig
AW: Spaltenvergleich, dann Wert (WENN bzw. SVERWEIS?)
13.12.2011 10:24:45
Rudi
Hallo,
vollkommen falsch Syntax für den Sverweis! Excel gut?
=WENN(ISTNV(SVERWEIS(G2;Pers_Kostl!A:B;2;0));"";SVERWEIS(G2;Pers_Kostl!A:B; 2;0))
Gruß
Rudi
AW: Spaltenvergleich, dann Wert (WENN bzw. SVERWEIS?)
13.12.2011 11:13:08
Ludwig
Vielen Dank!
Diese Formel hatte ich zuerst auch, habe allerdings nicht bedacht, diese mit "A:B" anzusetzen.
Aber irgendwie ist da bei mir der Wurm drin.
Wenn ich diese Formel für eine ähnliche Datei verwende, die vom Aufbau her gleich ist, zeigt die Zelle nichts an. Hab schon gesucht, aber nichts gefunden an was es liegen könnte.
=WENN(ISTNV(SVERWEIS(A2;ABRV!A:B;2;0));"";SVERWEIS(A2;ABRV!A:B;2;0))
Reiter 1: O. g. Formel in Spalte B, Spalte A soll abgeglichen werden mit dem Reiter "ABRV" Spalte A und deren Werte aus Spalte B übernommen werden, wenn die Angaben in Spalte B identisch sind.
Ich sehe vor lauter Wald keine Bäume mehr! :(
Wäre für Tips dankbar wo der Fehler liegt (ausser vor derm PC) :)
Anzeige
AW: Spaltenvergleich, dann Wert (WENN bzw. SVERWEIS?)
13.12.2011 11:20:05
Ludwig
Meinte natürlich:
Reiter 1: O. g. Formel in Spalte B, Spalte A soll abgeglichen werden mit dem Reiter "ABRV" Spalte A und deren Werte aus Spalte B übernommen werden, wenn die Angaben in Spalte A identisch sind.
Es scheint wohl irgendwie am 2. SVERWEIS (Sonst Wert) zu liegen, da hier der Funktionsassisten "NV" anzeigt.
AW: Spaltenvergleich, dann Wert (WENN bzw. SVERWEIS?)
13.12.2011 11:29:44
Rudi
Hallo,
da hier der Funktionsassisten "NV" anzeigt.
dann ist der Wert nicht vorhanden.
Gruß
Rudi
AW: Spaltenvergleich, dann Wert (WENN bzw. SVERWEIS?)
13.12.2011 11:34:08
Ludwig
Wie schon beschrieben, es lag daran, dass die Nummern in Spalte A (im 1. Reiter) als Text formatiert waren.
Danke nochmal
ERLEDGT
13.12.2011 11:26:36
Ludwig
Gut, wenn die Zahl als Text gespeichert wurde! :(
Jetzt funktioniert es.
Danke Rudi
Anzeige

366 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige