=ZÄHLENWENN(B38:O38;"0,25t")*0,25+ZÄHLENWENN(B38:O

Bild

Betrifft: =ZÄHLENWENN(B38:O38;"0,25t")*0,25+ZÄHLENWENN(B38:O
von: Ute B.
Geschrieben am: 25.09.2003 11:10:49

Hallo,

ich möchte bei meiner Stundenerfassung meine Stunden nicht nur im Viertelstundentakt erfassen, sondern im 5 Minutentakt. Erschwerden kommt hinzu das ich meine Tätigkeiten mit unterschiedlichen Buchstaben belege, so wie im unteren Beispiel mit "t" für turnusmäßige Tätigkeit oder "o" für Orga oder "em" wie E-mail bearbeiten. Meine bisherige Formel lautet: =ZÄHLENWENN(B48:O48;"0,25o")*0,25+ZÄHLENWENN(B48:O48;"0,5o")*0,5+ZÄHLENWENN(B48:O48;"0,75o")*0,75+ZÄHLENWENN(B48:O48;"o")+ZÄHLENWENN(B48:O48;"1,25o")*1,25+ZÄHLENWENN(B48:O48;"1,5o")*1,5+ZÄHLENWENN(B48:O48;"1,75o")*1,75.
Ich könnte natürlich alle Buchstaben eingeben und eine 5 Minutenaufteilung, aber die Formelgröße ist nunmal begrenzt. Wenn mir da jemdand helfen kann, eine Lösung zu finden, all diese Anforderungen unter einen Hut zu bringen, wäre ich sehr dankbar.

Ute

Bild


Betrifft: AW: =ZÄHLENWENN(B38:O38;"0,25t")*0,25+ZÄHLENWENN(B38:O
von: Karl-Otto Reimann
Geschrieben am: 25.09.2003 11:29:55

Hallo Ute

Wie sieht die Tabelle aus?
Ich vermute, Du kommst mit =HÄUFIGKEIT() weiter,
denn jeden Wert der Matrix kannst Du weiterberechnen.

Glück Auf
K.O.


Bild


Betrifft: AW: =ZÄHLENWENN(B38:O38;"0,25t")*0,25+ZÄHLENWENN(B38:O
von: Holger Levetzow
Geschrieben am: 25.09.2003 12:17:43

versuche mal folgende Matrixformel ( die { } nicht eingeben, sondern Formeleingabe mit Strg+Umsch+Enter abschließen

{=SUMME(WENN(LINKS(B48:O48)="o";RECHTS(B48:O48;LÄNGE(B48:O48)-1)*1;0))}

das ist das Beispiel für o... (t analog, bei em natürlich -2)
Holger


Bild


Betrifft: AW: =ZÄHLENWENN(B38:O38;"0,25t")*0,25+ZÄHLENWENN(B38:O
von: Günther Oppold
Geschrieben am: 25.09.2003 12:58:01

5 Minuten sind in Dezimale umgerechnet 0,0833333.
Wie lauten denn Deine Dezimalzahlen, die Du aufsummieren willst?

mit dieser Formel werden alle Zellen summiert, bei denen rechts "o" steht und die mit #,#5 enden. Veilleicht gibt dies einen Anstoß
=SUMMENPRODUKT((RECHTS(C1:C21)="o")*(RUNDEN(REST(LINKS(C1:C21;LÄNGE(C1:C21)-1)*1;0,05);2)=0)*LINKS(C1:C21;LÄNGE(C1:C21)-1)*1)

Gruß
Günther


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Funktion INDEX"