Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
240to244
240to244
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Wenn - Dann Bedingung

Wenn - Dann Bedingung
11.04.2003 14:25:21
Peter
Hallo,

folgendes Problem: Die Wenn-Dann Bedingung ist auf 7 "Wenns" beschränkt. Ich muß jedoch mehr "Wenns" unnterbringen.
Bitte helft mir!

Dank im voraus.


2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Re: Wenn - Dann Bedingung
11.04.2003 14:26:54
Forum

Hallo Peter

ein klares NEin.

Bei so vielen wenns sollte man aber über den Einsatz eines Verweises nachdenken.


Mehr als 8 Wenn
http://www.excelformeln.de/formeln.html?welcher=128
=WENN(A1=1;1;WENN(A1=2;2;WENN(A1=3;3;WENN(A1=4;4;WENN(A1=5;5;WENN(A1=6;6;WENN(A1=7;7;)))))))+WENN(A1=8;8;WENN(A1=9;9;WENN(A1=10;10;WENN(A1=11;11;WENN(A1=12;12;)))))
von WF
Die Grenze liegt bei 1024 Zeichen für die Formel.


Gruß

Re: Wenn - Dann Bedingung
11.04.2003 14:43:09
BernhardStock

Verteil die Wenns auf zwei Zellen: wenn 1-6 zum auswerten,
7. wenn verweist auf 2. Zelle, dort nochmal wenn 1-7 macht schon 13

z.B. so

Zelle C16
WENN(C15>0;C15+Blatt1!B7;WENN(C14>0;C14+Blatt1!B7;WENN(C13>0;C13+Blatt1!B7;WENN(C12>0;C12+Blatt1!B7;WENN(C11>0;C11+Blatt1!B7;WENN(C10>0;C10+Blatt1!B7;WENN(C9>0;C9+Blatt1!B7;WENN(C8>0;C8+Blatt1!B7;C17))))))))

Zelle C17
WENN(C7>0;C7;WENN(C6>0;C6;WENN(C5>0;C5;C4)))+Blatt1!B7

Bernhard

Anzeige

319 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige