Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
280to284
280to284
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Verschachtelung von Wenn-Dann-Formel

Verschachtelung von Wenn-Dann-Formel
22.07.2003 11:40:52
J. Fallasch
Ich bastele gerade ein Reisekosten-Formular in der die Spesen automatisch ausgerechnet werden sollen.
Dienstreisebeginn und -ende werden eingetragen (im Uhrzeiten-Format, Feld I7).
Die Formel soll anzeigen: Reisen unter 8h = 0€ Spesen, bis 14h = 6€, über 14h = 12€, über 24h = 24€:
Ich hab zwar schon was gebastelt, aber der Wert bleibt bei 6€ stehen, auch wenn die h-Zahl höher ist (meine Formel: =WENN(I7<14;6;WENN(I7>14;12;0)))
Habe die Fälle 0€ und 24€ rausgelassen, sollten aber eigentlich mit rein.
Kann mir jemand die richtige Formel sagen?
Herzlichen Dank für eventuelle Hilfe. ;-)
J.

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Verschachtelung von Wenn-Dann-Formel
22.07.2003 11:58:28
Michael
Hallo

Versuchs mal damit. Das Problem ist das Uhrzeitformat. Im Zahlenformat funktioniert die Formel.

=WENN(UND(B10>8;B10<14);6;WENN(UND(B10>14;B10<24);12;WENN(B10>24;24;0)))

Gruß
Michael


AW: Verschachtelung von Wenn-Dann-Formel
22.07.2003 11:45:06
andreas e
hallo j,

so müsste die Formel aussehen:
=WENN(I7>24;24;WENN(I7>14;12;WENN(I7>8;6;0)))

wobeio ich gerade dachte ob dein problem wohl daher kommt, daß du Uhrzeiten ermittelst und nicht mit Faktor 24 multiplizierst ?
gruß
andreas e
http://www.skripteundaufgaben.de
viele kostenlose downloads zu excel und mehr


Anzeige
AW: Verschachtelung von Wenn-Dann-Formel
22.07.2003 11:50:36
Janine
Mille grazie! Dass mit Faktor 24, wär mir nie eingefallen. Aber es klappt jetzt.
J.


327 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige