mehr als 7 wenn-dann-Verschachtelungen

Bild

Betrifft: mehr als 7 wenn-dann-Verschachtelungen von: Hannes1
Geschrieben am: 16.02.2005 15:47:35

Hallo Leute,

wie ich sehe, sind hier einige Profis am Werk, was man von mir leider (noch) nicht behaupten kann.

Habe folgendes Problem:

Je nachdem welchen Wert (1-12) eine bestimmte Zelle hat, soll ein bestimmtes Ergebnis angegeben werden !? Reicht das? Als Beispiel mal meine Formel:

=wenn(B1=1;"Januar";wenn(B1=2;"Februar";wenn(B1=3;"März";wenn(B1=4;"April" ... usw.

Leider sind vom System aber nur 7 Verschachtelung erlaubt. (Bei Einbettung in eine oder-Funktion mit 12 wenn-Funktionen, erhalte ich den Fehler "#Wert")

Hinweis:
der Wert von B1 ist ein Ergebnis. Später in der Tabelle wird anstatt von Monatsnamen auch mit Werten gerechnet, weshalb ich für Lösungen zur Berechnung von Monaten zwar dankbar bin, dies löst aber mein Problem nicht endgültig.

Vielen Dank schon mal im Voraus

Schöne Grüße
Hannes1

PS: Durchaus möglich, dass ich mich erst wieder am WE melden kann

Bild


Betrifft: www.excelformeln.de von: Jan
Geschrieben am: 16.02.2005 15:48:15

f


Bild


Betrifft: AW: mehr als 7 wenn-dann-Verschachtelungen von: KlausF
Geschrieben am: 16.02.2005 15:59:25

Hallo, Hannes der Erste!

Vielleicht hilft Dir die WAHL-Funktion?
=WAHL(B1;"Januar";"Februar";"März";.....;"Dezember")
bzw. anstelle der Monatsnamen Werte oder Verweise auf andere Zellen.

Gruß
Klaus


Bild


Betrifft: AW: Danke von: Hannes1
Geschrieben am: 16.02.2005 16:35:08

Wahnsinn, ich bin begeistert.

So schnell habe ich bisher in keinem Forum eine ausreichende Lösung erhalten.
Vielen Dank, werde Euch weiterempfehen, bzw mich bald wieder an Euch wenden, grins

Gruß
Hannes1


Bild


Betrifft: AW: mehr als 7 wenn-dann-Verschachtelungen von: =Peter=
Geschrieben am: 16.02.2005 16:35:59

Hallo Hannes,

Sverweis wäre IMHO auch eine Möglichkeit:

Tabelle1
 CDEF
14April1Januar
2  2Februar
3  3März
4  4April
Formeln der Tabelle
D1 : =SVERWEIS(C1;E1:F4;2;WAHR)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


HTH
Gruss
Peter


 Bild

Beiträge aus den Excel-Beispielen zum Thema "zellwerte in minuswerte umwandeln"