Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

INDEX jede zweite Zeile wenn nicht leer

INDEX jede zweite Zeile wenn nicht leer
28.09.2021 09:21:31
Ben
Guten Morgen,
ich brauche Hilfe bei der Bearbeitung einer Tabelle.
Ich möchte aus einer vorhandenen Tabelle den Inhalt teilweise weiter nutzen. Dazu müssen die Zellen zeilenweise abgefragt und in eine Spalte überführt werden. Dabei soll aber nur jede zweite Zeile berücksichtigt werden. In der der Zielspalte sollen keine leeren Zellen aufgeführt werden.
Vielen Dank im Voraus!!
Grüße
Ben
Im Beispiel rechts das gewünschte Ergebnis:
Userbild

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: =INDEX(A:A;ZEILE(A1)*2-1) owT
28.09.2021 09:29:15
neopa
Gruß Werner
.. , - ...
AW: =INDEX(A:A;ZEILE(A1)*2-1) owT
28.09.2021 09:49:21
Ben
Danke für die schnelle Antwort!
Im Ergebnis fehlen für mich aber noch die Texte 4,5 und 8.
Wie kann ich das noch mit hinzufügen?
AW: ok, nachgefragt ...
28.09.2021 09:59:36
neopa
Hallo Ben,
... sorry, ich hatte nicht richtig gelesen.
Nun nachgefragt: Wie viele Spalten sind denn wirklich auszuwerten? Sind alle anderen Zellen wirklich leer?
Gruß Werner
.. , - ...
AW: ok, nachgefragt ...
28.09.2021 10:18:31
Ben
Es sind maximal 5 Spalten auszuwerten und die Zellen sind wirklich leer.
AW: dann ...
28.09.2021 10:24:47
neopa
Hallo Ben,
... z.B. für bis zu 99 Datensätze mit folgender Formel in G1, die möglicherweise noch gekürzt werden könnte.
=WENNFEHLER(INDEX(A:E;AGGREGAT(15;6;ZEILE(A$1:A$99)/REST(ZEILE(A$1:A$99);2)/(A$1:E$99"");ZEILE(A1));REST(AGGREGAT(15;6;(ZEILE(A$1:A$99)+SPALTE(A$1:E$1)%)/REST(ZEILE(A$1:A$99);2)/(A$1:E$99"");ZEILE(A1));1)*100);"")
Gruß Werner
.. , - ...
Anzeige
AW: dann ...
28.09.2021 11:09:47
Ben
Werner, perfekt! Genau wie gewünscht.
Vielen Dank für die super schnelle Hilfe!
Jetzt muss ich "nur" noch versuchen es nachzuvollziehen ...
Beste Grüße
Ben
AW: bitteschön owT
28.09.2021 11:16:16
neopa
Gruß Werner
.. , - ...

362 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige