Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summe wenn unten ungleich oben

Summe wenn unten ungleich oben
23.09.2016 14:26:22
Doddi
Hallo ich habe folgendes Problem.
Ich importiere Daten aus einer DB in Excel,
ein Beispiel
250 -- 50 -- f1
250 -- 50 -- f2
120 -- 10 -- f5
80 -- 0 --
50 -- 20 -- f7
50 -- 20 -- f1
50 -- 20 -- f3
Ich soll nun die Summe aus der ersten und zweiten Spalte bilden, aber nur aus den Werten, die danach nicht doppelt vorkommen.
Also im Beispiel wären es
1. Spalte 250+120+80+20
2. Spalte 50+10+0+20
Ich habe es mit SUMMEWENN und SUMME und WENN und SUMMEWENNS probiert aber entweder ist das Ergebnis 0 oder es werden alle Zahlen aufsummiert ohne die Beachtung von .
Vielen Dank für eure Hilfe

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Summe wenn unten ungleich oben
23.09.2016 14:34:51
Rudi
Hallo,
per Hilfsspalte: =A1*(ZÄHLENWENN(A$1:A1;A1)=1), runterkopieren und die Summe bilden.
Gruß
Rudi
AW: Summe wenn unten ungleich oben
23.09.2016 14:37:15
Daniel
Hi
Probier mal
=SummenProdukt(A1:A99/ZählenWenn(A1:A99;A1:A199))
der Zellbereich in der Formel muss so gut wie möglich an den tatsächlichen Zellbereich angepasst werden.
Gruß Daniel
AW: Summe wenn unten ungleich oben
23.09.2016 14:52:50
Doddi
Vielen Dank für eure Hilfe
beide Antworten funktionieren gut
nur kann es vorkommen, dass die Anzahl in der Spalte öfter vorkommen, sodas in der Hilfsspalte leider eine 0 kommt statt dem Wert.
Somit sollte nur geprüft werden ob die Zahl darunter undlgeich ist, wenn ja addieren.
822 822
191 191
191 0
654 654
654 0
191 0
191 0
620 620
1000 1000
1000 0
200 200
654 0
654 0
654 0
Anzeige
=SUMMENPRODUKT((A1:A98<>A2:A99)*A1:A98)
23.09.2016 15:04:04
WF
.
AW: =SUMMENPRODUKT((A1:A98<>A2:A99)*A1:A98)
26.09.2016 15:30:42
Doddi
Vielen Dank für die vielen Antworten.
Hat alles super funktioniert.
Neues Problem
Die Werte der DB sollen direkt als Pivot ausgegeben werden
Wenn ich nun die Formel, die bei einer Excel Tabelle wunderbar funktionieren, bei Berechnung in Pivot eingebe funktioniert es nicht mehr.
Kann das Pivot direkt oder müssten wir über den Umweg DB / Tabelle / Pivot gehen ?

310 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige