Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema TextBox
BildScreenshot zu TextBox TextBox-Seite mit Beispielarbeitsmappe aufrufen

DRINGEND - Summe berechnen mit rel. und absoluten

Betrifft: DRINGEND - Summe berechnen mit rel. und absoluten von: Didi
Geschrieben am: 20.09.2004 14:52:22

Hallo,
habe folgendes Problem:

Ich möchte eine kumulierte Monatsberechnung durchführen.
Wenn ich nun ein neues Monat eingebe und zwar links vom kumulierten Wert soll in der kumulierten Zelle sich der Wert um den neuen Monat erweitern.
Ich bräuchte also eine Formel, die alles links der kumulierten Zelle addiert, oder eine Formel wie ActiveCell.FormulaR1C1 ="SUM(F11:RC[-1])" - also einen absoluten und einen rrelativen Bezug.

Danke für die Antworten

  


Betrifft: AW: DRINGEND - Summe berechnen mit rel. und absoluten von: Dr.
Geschrieben am: 20.09.2004 14:56:44

Verstehe das Problem nicht. Wenn die Summenformel eh über den ganzen Bereich geht, wird doch auch bei Einfügen einer neuen Spalte der Wert innerhalb des Bereiches mitsummiert!??!!


  


Betrifft: AW: DRINGEND - Summe berechnen mit rel. und absoluten von: didi
Geschrieben am: 20.09.2004 15:20:38

Nein, das funktioniert leider nicht.
Die Formel heißt z.b. =Summe(A1:H1), sagen wir für die ersten 8 Monate. In der Spalte I ist die Summenformel.
Gebe ich jetzt einen neuen Monat September ein - in der Spalte I - Summenformel wird auf J verschoben - wird die Formel nicht erweitert.

Wäre für Beiträge dankbar


  


Betrifft: In I1: =SUMME(A1:INDIREKT("ZS(-1)";)) von: Boris
Geschrieben am: 20.09.2004 15:27:01

Grüße Boris


  


Betrifft: AW: In I1: =SUMME(A1:INDIREKT("ZS(-1)";)) von: didi
Geschrieben am: 20.09.2004 15:46:28

genial, vielen dank, genau das habe ich gesucht!!!
dankeschön für alle antworten und schönen tag


  


Betrifft: AW: DRINGEND - Summe berechnen mit rel. und absoluten von: Annett
Geschrieben am: 20.09.2004 15:00:24

Hallo didi

füge vor der Summenspalte eine Leerspalte ein, die Bestandteil der Summenformel ist. Füge jetzt vor der Leerspalte eine neue Spalte ein.

Gruß Annett


  


Betrifft: AW: DRINGEND - Summe berechnen mit rel. und absoluten von: didi
Geschrieben am: 20.09.2004 15:21:48

danke, so funktioniert es zumindest.
weißt du evt. eine schönere Lösung?
dankeschön auf alle fälle
lg


 

Beiträge aus den Excel-Beispielen zum Thema "DRINGEND - Summe berechnen mit rel. und absoluten "