Textzellen addieren

Bild

Betrifft: Textzellen addieren
von: Jörg
Geschrieben am: 19.11.2003 17:41:07

Hallo,

ich brauche mal Eure Hilfe da ich noch nie mit Textfeldern gearbeitet habe:

Aufgabe: ich habe 2 Zellen deren Inhalt Text ist:
Zelle 1: A10-122-321
Zelle 2: 56753-0001

ich muss jetzt hieraus mittels eines Makros eine neue Zelle erzeugen:
und zwar: Zelle 3: A10-122-321-0001

also den Inhalt der Zelle 1 + die letzten 5 zeichen der Zelle 2.
im Idealfall führe ich die Funktion nur aus wenn
z.B. die Zelle 2 kürzer als 11 Zeichen ist
(das wär aber nur der Bonbon;-)

weiss jemand wie sowas geht?

Thanx
Jörg

Bild


Betrifft: AW: Textzellen addieren
von: th.heinrich
Geschrieben am: 19.11.2003 17:46:07

hallo Jörg,

=A16&RECHTS(A17;5)

am bonbon lutsche ich noch ;-)

gruss thomas


Bild


Betrifft: bonbon
von: th.heinrich
Geschrieben am: 19.11.2003 17:50:13

hallo Jörg,

=WENN(LÄNGE(A17)<11;A16&RECHTS(A17;5);"")

gruss thomas


Bild


Betrifft: AW: Textzellen addieren
von: OliveR
Geschrieben am: 19.11.2003 17:52:39

Hallo Jörg,

here we go.

Gruß
OliveR


Sub verketten()
Dim lR%, i%
lR = 10
For i = 1 To lR Step 1
If Len(Cells(i, 2)) < 11 Then
    Cells(i, 3) = Cells(i, 1) + Right(Cells(i, 2), 5)
End If
Next i
End Sub



Bild

Beiträge aus den Excel-Beispielen zum Thema " Textzellen addieren"