in Notentabellen Summen bilden



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: in Notentabellen Summen bilden
von: Heiko
Geschrieben am: 10.07.2002 - 20:36:07

Ich habe seit längerer Zeit ein Problem:
Ich habe eine Notentabelle, in der ich Z.B nebeneinander in den Spalten folgende Daten stehen habe:
3- 4 3 3+ 2- befreit 4 4+ 2- ne 4
Wie kann ich aus diesen Noten durch Eingabe einer Formel den Mittelwert berechnen?
Die Anzahl-Berechnung funktioniert und liefert mir im obigen Beispiel den Wert 9 (insgesamt 9 Zensuren. In der Summenberechnung wende ich die Funktion Summe (Links (Zellbezug);1);Links(Zellbezug2);1;...... an und aus der 3- wird z.B eine 3.
Probleme bereiten mir die Zellen, in denen Texte stehen (befreit, ne). Prinzipell auslassen in der Summenberechnung darf man diese Spalten nicht, weil sie auch mit Noten belegt sein können.
Wie kann ich eine Formel eingeben, die aus obiger Zeile den Wert 29 als Summe und 3,22 als Mittelwert liefert, ohne dabei die Textspalte mit "befreit" und "ne" auszuklammern?
Ich möchte nach Möglichkeit keine zusätzlichen Zeilen aufmachen und das Problem auch nicht mit einem Makro lösen.

Viele Grüße Heiko

nach oben   nach unten

Re: in Notentabellen Summen bilden
von: Hans W. Hofmann
Geschrieben am: 10.07.2002 - 20:54:02

Hübsche Aufgabe :-),

ich würde eine Arrayfunktion vorschlagen:
Eingabe mit Strg+Umschalt+Eingabetaste abschließen...
Deine Noten stehen z.B. von A16:A25

=SUMME((CODE(A16:A25)-48)*(CODE(A16:A25)-48<10))/SUMME((CODE(A16:A25)-48<10)*1)

BTW: Was machste denn erst Verzierungen wie +/- an die Noten, wenn sie dann eh nix zählen?


Gruß HW

nach oben   nach unten

Re: in Notentabellen Summen bilden
von: Heiko
Geschrieben am: 10.07.2002 - 22:02:26

Danke HW!

Deine Idee mit dem Code-Befehl hat mich weitergebracht, wenn auch die Formel wohl noch nicht ganz richtig ist..

Zu deiner Bemerkung am Schluss:
In den Zeugniskonferenzen sind die Notenanhängsel für Versetzungswarnungen wichtig, dürfen aber in den Zeugnissen oder in der Mittelwertbildung nicht berücksichtigt werden.
Also nochmals vielen Dank!

Gruß Heiko

nach oben   nach unten

Re: in Notentabellen Summen bilden
von: Hans W Hofmann
Geschrieben am: 10.07.2002 - 22:33:59

Und was stimmt mit der Formel nicht.
Laß mich nicht dumm sterben ;-)

Gruß HW


nach oben   nach unten

Re: in Notentabellen Summen bilden
von: Heiko
Geschrieben am: 10.07.2002 - 22:50:04

Hallo HW.
Deine Formel habe ich kopiert und mit Noten versehen, aber ich bekam negative Werte.
Habe jetzt folgende Formel als Array:
{=SUMME(WENN((CODE(A1:E1)-48>0)*(CODE(A1:E1)-48<10);CODE(A1:E1)-48))/(ANZAHL(WENN((CODE(A1:E1)-48>0)*(CODE(A1:E1)-48<10);CODE(A1:E1))))}
Vielleicht ein paar überflüssige Klammern, aber der Mittelwert wird exact berechnet.

Also noch einmal vielen Dank für den Tipp mit dem "Code"

Gruß Heiko

nach oben   nach unten

problem
von: th.heinrich
Geschrieben am: 11.07.2002 - 01:51:30

guten morgen Heiko,

falls Du wirklich lehrer bist muss die PISA STUDIE erweitert werden.

nicht die schueler(in) sind doof, sondern die lehrer welche die noten "als problem" berechnen.

schade thomas


nach oben   nach unten

problem
von: th.heinrich
Geschrieben am: 11.07.2002 - 01:59:11

guten morgen Heiko,

falls Du wirklich lehrer bist muss die PISA STUDIE erweitert werden.

nicht die schueler(in) sind doof, sondern die lehrer welche die noten "als problem" berechnen.

schade thomas


nach oben   nach unten

Re: problem
von: Heiko
Geschrieben am: 11.07.2002 - 10:17:22

Hallo Thomas!
Danke für die konstruktive Kritik.
Hast du eine Lösung parat?
Oder willst du Frust abbauen?
Deine Äusserung müsstest du noch kommentieren!
Gruß Heiko

nach oben   nach unten

Re: problem
von: th.heinrich
Geschrieben am: 11.07.2002 - 17:22:41

hallo Heiko,

sorry man darf nach einem kneipenbummel (1:59) nicht mehr das Forum besuchen. habe in Deinem thread etwas gelesen was gar nicht drin steht.

bin froh, dass Du eine loesung erhalten hast.

pardon th.heinrich

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "in Notentabellen Summen bilden"