Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert gibt 0 aus

    Betrifft: Mittelwert gibt 0 aus von: Manfred
    Geschrieben am: 02.10.2003 14:40:30

    Liebe Excellenten,

    ich möchte in einer Tabelle den kleinsten Wert =Min() herausfinden.
    Allerdings sollen nur bestimmte Zellen in die Berechnung
    einfließen.

    Beispiel
    Gültig...Angebot...Preis
    J.............J.............1,5
    J.............J.............1,4
    J.............J.............1,3
    N............J.............1,2
    N............J.............1,1

    1) =MIN(WENN(Gültig="J";WENN(Angebot="J";Preis)))=1,3 -> richtig
    2) =MIN(WENN(Gültig="J";WENN(Angebot="N";Preis)))=0 -> falsch
    -> es gibt keinen Preis, der diese Bedingung erfüllt,
    die 0 ist also falsch. Ich brauche entweder eine
    Fehlermeldung oder (besser) eine Textangabe, die ich
    bestimmen kann (z.B. "Keine Wert"), wenn die Bedingungen
    keinen Minimalwert finden lassen.

    Ich freue mich auf Eure Vorschläge
    Manfred

      


    Betrifft: AW: Mittelwert oder MINIMUM ? von: th.heinrich
    Geschrieben am: 02.10.2003 15:02:09

    hallo Manfred,

    das ist hier die frage ;-)

    nehme an Du willst MIN aus C:C wenn in A UND B ein "J" steht.

    =WENN(UND(A1;B1="j");MIN(C:C);"kein Wert")

    gruss thomas


      


    Betrifft: AW: Mittelwert oder MINIMUM ? von: Manfred
    Geschrieben am: 02.10.2003 15:36:51

    Mein lieber Heinrich ....

    natürlich geht es im den kleinsten Wert.

    Deine Formel passt noch nicht so ganz.
    Auch wenn ich die Wenn-Bedingungen nicht wie in Deiner
    Formel auf Zellen sondern auf ganze Spalten beziehe,
    sucht sich die Formel aus der gesamten Preisspalte
    den kleinsten Wert und nicht (nur) aus den Zellen, die
    in einer Zeile stehen, in der die Bedingungen zutreffen.
    Als weitere Schwierigkeit: Es kann in der "Preis-Spalte"
    auch mal ein "x" drinstehen.

    Noch eine Idee?

    Manfred


      


    Betrifft: AW: Mittelwert oder MINIMUM ? von: börni
    Geschrieben am: 02.10.2003 15:45:34

    hallo manfred,

    ich hätts mal so probiert:

    in eine spalte kommt =WENN(UND(A1="J";B1="J");C1;"")
    die ziehst du bis zum letzten wert hinunter und blendest die spalte dann aus.

    dann in die spalte daneben =MIN(E:E)

    was du allerdings damit mit dem X dann meinst, weiß ich nicht! weil entweder gibt es ein Angebot/Gültigkeit (J) oder eben nicht (N). was würde das X dann bedeuten?

    gruß

    börni


      


    Betrifft: Neuer Ansatz: AW: Mittelwert oder MINIMUM ? von: Manfred
    Geschrieben am: 02.10.2003 16:10:09

    Liebe Excellenten,

    Ich erklärs mal anders (auch mit einem anderen Beispiel)

    ich möchte in einer Tabelle den kleinsten Wert =Min() herausfinden.
    Allerdings sollen nur bestimmte Zellen in die Berechnung
    einfließen.

    Etikett.....Preis_Regal
    J.............1,5
    J.............1,4
    J.............x
    N............1,2
    N............1,2

    "Etikett" und "Preis_Regal" sind jeweils Namen für die gesamte Spalte.

    Formel.......................................................................Formel-Ergebnis...................Richtiges-Ergebnis
    1) WENN(Etikett="J";MIN(Preis_Regal);"kein Wert" .......1,2...............................................1,4
    2) WENN(Etikett="N";MIN(Preis_Regal);"kein Wert")......kein Wert...................................1,2


    1) -> falsch (die ersten drei Zeilen, welche die Bedingung erfüllen, haben als Minimum eine 1,4 (1,5; 1,4; "x")
    2) -> falsch (keinen Schimmer wie die Formel auf dieses Ergebnis kommt)

    Eine Hilfsspalte ist in meinem Fall nicht zweckmäßig, weil
    ich die Bedingungen, unter denen der Minimalwert ausgerechnet werden soll
    in meinem Auswerteblatt variabel halten möchte.
    Es ist auch nur in diesem Beispiel eine Bedingung, da facto sind es 4 Bedingungen,
    die ich berücksichtigen muss.

    Geht noch einer?
    Manfred


      


    Betrifft: Neuer Ansatz: AW: Mittelwert oder MINIMUM ? von: börni
    Geschrieben am: 02.10.2003 16:13:10

    tut mir leid, da würd ichs mit Code probieren. aber wie das dann geht, darfst
    du mich nicht fragen, so gut kenn ich mich nicht aus :o)


      


    Betrifft: kkleinste-wenn-ARRAY von: Günther Oppold
    Geschrieben am: 02.10.2003 16:53:01

    Hi Börni,

    mit folgender Formel hat's bei mir funktioniert:

    {=KKLEINSTE(WENN((A2:A6="J")*(B2:B6>0);B2:B6);1)}

    ARRAY-Formel: die geschweifte Klammer nicht eingeben, sondern die Formeleingabe abschließen mit Strg+Umsch+Enter

    Günther


      


    Betrifft: AW: kkleinste-wenn-ARRAY von: th.heinrich
    Geschrieben am: 02.10.2003 17:08:59

    hallo Günther,

    die FORMEL ist ja schon fast Borisverdaechtig ;-))

    gruss thomas


      


    Betrifft: AW: kkleinste-wenn-ARRAY von: Manfred
    Geschrieben am: 02.10.2003 19:00:20

    Hi Günther,

    das funkt - Danke.
    Und ganz nebenbei ist die Formel (wenn man sie kennt)
    unkompliziert (du solltest mal die Formel-Schlangen
    sehen, die ich ausprobiert habe).

    Schönes Wochenende
    Manfred


     

    Beiträge aus den Excel-Beispielen zum Thema " Mittelwert gibt 0 aus"