Microsoft Excel

Herbers Excel/VBA-Archiv

Zahl und Text mit Textfarbenformatierung?

Betrifft: Zahl und Text mit Textfarbenformatierung? von: Burghard
Geschrieben am: 24.07.2014 21:28:31

Hallo,

meine Frage: Kann man bei einer Kombination von Text und Zahl nicht nur das Zahlenformat, sondern vielleicht auch die Textfarbe mitformatieren?
Beispiel (Zelle hat Zeilenumbruch):

=SUMME($A$5:$A$11)+SUMME(14)&" Tassen"&ZEICHEN(10)&" - "&ZEICHEN(10)&TEXT(SUMME($A$1) +SUMME($A$12:$A$28);"0")&" Tassen Ausgabe"&ZEICHEN(10)&" = "&ZEICHEN(10)&TEXT(SUMME($A$5:$A$11) +SUMME(12)-SUMME($A$12:$A$28);"0") &" Soll Tassen"

in etwa so (geht aber so nicht):

=SUMME($A$5:$A$11)+SUMME(14)[BLAU]&" Tassen"&ZEICHEN(10)&" - "&ZEICHEN(10)&TEXT(SUMME($A$1) +SUMME($A$12:$A$28);"0")&" Tassen Ausgabe"&ZEICHEN(10)&" = "&ZEICHEN(10)&TEXT(SUMME($A$5:$A$11) +SUMME(12)-SUMME($A$12:$A$28);"0") &" Soll Tassen"

Ich will nicht die Zelle als Ganzes, sondern nur den ersten Zahlenteil blau formatieren. Gibt es dafür eine Lösung? Oder geht das schlichtweg nicht?

Grüße Burghard

  

Betrifft: AW: Zahl und Text mit Textfarbenformatierung? von: ransi
Geschrieben am: 24.07.2014 22:30:48

Hallo

DAs geht nur mit VBA.
Das Ergebniss mit VBA berechnen, in die Zelle schreiben und dann den Zahlenteil separat formatiern.

Aber was soll das ?
SUMME(14)

ransi


  

Betrifft: evtl. könnte auch die "Kamera" helfen ... von: der neopa
Geschrieben am: 25.07.2014 08:05:04

Hallo Burghard,

... allerdings ist das einer VBA-Lösung nur im Ausnahmefall vorzuziehen. Im Bedarfsfall einfach mal nach Excel und Kamera googeln.

Gruß Werner
.. , - ...


  

Betrifft: Textformatierung in Funktionen nicht möglich ! von: NoNet
Geschrieben am: 25.07.2014 11:08:10

Hallo Burghard,

leider sind Textformatierungen (Farbe, Schriftart, Stil, Größe etc.) mit Formeln/Funktionen nicht möglich !
Eine Formel/Funktion liefert immer nur einen Wert zurück und zeigt diesen in der festgelegten Zellformatierung an.
Textformatierungen sind ansonsten nur bei kosntanten Werten manuell oder per VBA möglich.

Salut, NoNet


  

Betrifft: es geht schon, wenn auch nur über Umwege ... von: der neopa
Geschrieben am: 25.07.2014 11:24:34

Hallo NoNet,

... und zwar mit der Kamera und Hilfszellen. Hab ich zumindest selbst schon so getan. Es ist halt nur mit etwas Aufwand verbunden und keinesfalls geeignet, wenn dass mehr als zwei-, dreimal in einer Tabelle notwendig wird.
Aber funktionieren ohne VBA tut es schon, es ist nur nicht gerade empfehlenswert.

Gruß Werner
.. , - ...


  

Betrifft: In diesem Fall wären das keine Umwege... von: EtoPHG
Geschrieben am: 25.07.2014 11:33:10

Hallo zusammen,

Eigentlich wollte ich das Gleich wie NoNet schreiben, habe micht dann aber zurückgehalten ;-)
Zum Vorschlag von Werner's Umwege:
In vorliegenden Fall sind das IMHO keine Umwege. Es macht schlicht keinen Sinn in Formeln Zellinhalte aufzubauen, die a) aus variablen Werten (Formeln) und b) aus "Fixen Stringwerten" bestehen. Werden dies beiden in getrennten (nebeneinander stehenden) Zellen dargestellt, kann b) mit einfacher Standardformatierung 'umgefärbt' werden.
Auch für dieses Problem gilt wieder mal: "Form follows Function" und nicht zuerst auf schöne Darstellungen achten und dann am Ganzen scheitern...

In diesem Sinne: Schön formatiertes Wochenende, Hansueli


  

Betrifft: wenn man die Kamera nutzt, dann schon ... von: der neopa
Geschrieben am: 25.07.2014 11:48:50

Hallo Hansueli,

... aber nicht nur dann ;-)

Wenn man das beachtet, was Du schreibst, nicht :-)

Dir ein formvollendetes ;-) WE

Gruß Werner
.. , - ...


  

Betrifft: Es gibt natürlich Möglichkeiten, das so zu ... von: Luc:-?
Geschrieben am: 25.07.2014 15:25:07

…automatisieren, dass im Bedarfsfall entweder die Fml wieder zur Verfügung steht, nachdem ursprüngl ihr Ergebnis als Wert gespeichert und dann entsprd formatiert wurde, oder ein entsprd formatiertes Textfeld über das Ergebnis zu legen, wobei die Fml erhalten bleibt.
Gruß, Luc :-?