Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Anzahl Beträge ungleich Null mit wenn Abfrage

Anzahl Beträge ungleich Null mit wenn Abfrage
06.03.2009 13:00:35
Urs
Hallo zusammen
Ich habe eine Tabelle mit rund 12000 Zeilen.
In der Spalte A habe ich ca. 30 verschiedene Werte (z.B. 12,13,15,16,52,55,71,72 usw). In der Spalte U habe ich verschiede Werte (Einstandspreise). Ich habe jetzt die Addition der Spalte U mit Summewenn gelöst.
Formel:
=SUMMEWENN(VER300_alles!$A$2:$A$12000;A3;VER300_alles!$U$2:$U$12000)
Mein Problem ist, dass ich nicht nur die Summe sondern die Anzahl der Werte möchte, die nicht 0 sind und dem Wert in der Spalte A entsprechen. In der Summe ist der Nullwert ja kein Problem, aber in der Anzahl rechnet er Ihn mir immer mit.
Vielleicht kann mir ja jemand helfen, wie ich das Problem, wenn möglich ohne VBA lösen kann.
Vielen Dank für Eurer mithilfe!
Gruss
Urs

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Anzahl Beträge ungleich Null mit wenn Abfrage
06.03.2009 13:05:46
Josef
Hallo Urs,
meinst du so?
Tabelle2

 ABCDEFG
21550  152 
31650     
47124     
51450     
67235     
71448     
81619     
97141     
101623     
111546     
127230     
1315      
141650     
157124     
161450     
177235     
181448     
191619     
207141     
211623     
2215      
237230     
24       
25       

Formeln der Tabelle
ZelleFormel
F2=SUMMENPRODUKT((A2:A23=E2)*(B2:B23<>0))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp

Anzeige
AW: Anzahl Beträge ungleich Null mit wenn Abfrage
06.03.2009 13:41:20
Urs
Hallo Hajo
Hallo Sepp
Vielen Dank für Eure Hilfe hat super geklappt.
Wünsche Euch einen schönen Tag und ein erholsames Wochenende.
Gruss
Urs

309 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige