Microsoft Excel

Herbers Excel/VBA-Archiv

Werte vergleichen und mit ANZAHL2 zusammenrechnen



Excel-Version: Alle Versionen

Betrifft: Werte vergleichen und mit ANZAHL2 zusammenrechnen
von: Martin
Geschrieben am: 01.06.2002 - 17:39:54


Hallo,

ich habe zwei Spalten, die ich miteinander vergleichen will [A1:A10] und [B1:B10].
Ist in [A1:A10] ein Wert, der in der entsprechenden Zeile in [B1:B10] ebenfalls vorhanden ist, so soll dieser als "1" gezählt werden.

Bsp.:
A1= 1
A2= 2
A3= 3
A4= 4
A5= 5
A6= 6
A7= 7
A8= 8
A9= 9
A10= 10

B1= 2
B2= 2
B3= 2
B4= 2
B5= 2
B6= 2
B7= 2
B8= 2
B9= 2
B10= 10

gäbe als Ergebnis "2", weil die Werte in A2 und B2, sowie in A10 und B10 übereinstimmen.
Klingt einfach, ist es garantiert auch. Ich versuche aber schon seit einiger Zeit die Formel hierfür herauszufinden (Matrix?), schaffe es aber nicht.

DANKE für jede Hilfe.
Gruss,
Martin

  

Re: Werte vergleichen und mit ANZAHL2 zusammenrechnen
von: Heinz
Geschrieben am: 01.06.2002 - 17:47:23

Hallo Martin,
Wo soll das Ergebnis stehen? In einer Vergleichsspalte oder in einer Zelle?

Gruß

Heinz


  

in einer anderen Zelle oT
von: Martin
Geschrieben am: 01.06.2002 - 17:49:55

.

  

Re: Werte vergleichen und mit ANZAHL2 zusammenrechnen
von: Heinz
Geschrieben am: 01.06.2002 - 17:53:18

Hallo Martin,

man sollte erst mal alles zuende denken.

Hier die Formel:
{=SUMME(WENN(A1:A10=B1:B10;1;0)}
dies ist eine Matrixformel, bitte mit STRG+UMSCHALT+RETURN abschließen

Wenn der Vergleich in einer Spalte stehen soll reicht eine Wenn-Bedingung: =wenn(A1=b1;1;0) und am Ende einfach aufsummieren.

Einen schönen Sonntag

Heinz


  

Re: Werte vergleichen und mit ANZAHL2 zusammenrechnen
von: Martin
Geschrieben am: 01.06.2002 - 18:00:17

Danke Heinz, das war es! Ich wußte, dass es einfach war ;-)

Gruss,
Martin


 

Beiträge aus den Excel-Beispielen zum Thema "Werte vergleichen und mit ANZAHL2 zusammenrechnen"