Microsoft Excel

Herbers Excel/VBA-Archiv

zählenwenn mit mehreren Bedingungen



Excel-Version: 8.0 (Office 97)

Betrifft: zählenwenn mit mehreren Bedingungen
von: Andreas
Geschrieben am: 01.06.2002 - 19:13:48

Liebe Leute,

leider habe ich auf meine Anfage keine passende Lösung erhalten, desshalb versuche ich das ganze klarer zu formulieren:

Ich bräuchte eine Formel die mir folgendes errechnet.

In einem Arbeitsblatt sind in Spalten die Urlaube verschiedener Mitarbeiter jeweils mit einer "1" in der passenden Datumszeile eingetragen. In der 4. Zeile ist jeweils die Personalnummer eingetragen. In der ersten Spalte ist das Datum eingetragen von 1. Jänner 2002 bis ....... In den Spalten kann jeder Mitarbeiter öfters vorkommen aus diesem Grund sollte die Formel alle "1" aufsummieren die in in einer Spalte vorkommen in der die Personalnummer z.B. für den einen Mitarbeiter 40 ist (immer in einer Zeile) und in einer Zeile ist welche sich in dem gewünschten Monat (z.B. Zeile zwischen 1. Jänner und 31. Jänner) befindet.

Das ganze schaut so aus:

___________ Name: Andreas______Test_________Andreas
____________ NR.:____40__________10____________40__
Datum:
1. Jänner_____________1_____________________________
2. Jänner_____________1_____________________________
3. Jänner_________________________1_________________
4. Jänner_________________________1_____________1___
.
.
1. Feber________________________________________1___


In Summe sollte nun die Formel für den Mitarbeiter Andi mit der Nummer 40 3 Urlaubstage für den Jänner errechnen. Geht das mit einer Formel???

Ich hoffe, dass ihr mir helfen könnt, ich weiss nicht mehr weiter.....

Danke und LG

Andreas

  

Re: zählenwenn mit mehreren Bedingungen
von: Josef B
Geschrieben am: 01.06.2002 - 20:59:38

Hallo Andreas
Mit Excel kann man sehr viel machen. Es ist sogar möglich, eine Tabelle so aufzubauen, dass eine Auswertung dieser Tabelle beinahe nicht mehr möglich ist.
Nein im ernst. Du solltest deine Tabelle ein wenig umbauen.Ich würde die Datums-Spalte so belassen. Dann rechts pro Mitarbeiter nur eine Spalte verwenden.
Also Datem in Spalte A
Mitarbeiter 40 in Spalte B
Und nun die Formel für Jänner:
=SUMMENPRODUKT((MONAT(A1:A20)=1)*B1:B20)

MfG Josef

  

Re: zählenwenn mit mehreren Bedingungen
von: Andreas
Geschrieben am: 01.06.2002 - 21:31:39

Lieber Josef,

vielen Dank für deine nette Antwort. Ich habe schon ungefähr 20 Möglichkeiten versucht meine Tabelle so zu gestalten, dass ich pro Mitarbeiter nur eine Spalte bräuchte...dann hätte ich auch leicht eine Lösung finden können. Leider brauche ich aber mehrere Spalten pro Mitarbeiter, diese Lösung ist sicher schwer, deshalb habe ich mich auch an dieses Forum gewandt...mir zu erklären was man nicht alles in Excel "machen" kann....naja wenn es dir geholfen hat

LG

Andreas


  

Re: zählenwenn mit mehreren Bedingungen
von: Josef B
Geschrieben am: 01.06.2002 - 23:12:03

Hallo Andreas
Ich würde in diesem Falle die Tage wie oben beschrieben pro Spalte errechnen. Die Formeln sollten am besten in derselben Spalte stehen. Dann kannst Du mit:
= SUMMEWENN(B4:Z4;40;B50:Z50) die Summe pro Mitarbeiter errechnen.
Im meinem Beispiel sind die Mitarbeiter-Nummern in B4:Z4
Die Summen der Spalten in B50:Z50

MfG Josef

  

Re: zählenwenn mit mehreren Bedingungen
von: Andreas
Geschrieben am: 02.06.2002 - 01:59:14

Hi Josef,

Danke für deine Unterstützung..sorry, dass ich vorher ein bisschen forsch war aber ich war mit den Nerven langsam am Ende...habe mir jetzt mit einem Makro geholfen aber trotzdem Danke das Du geholfen hast!

>LG Andreas


 

Beiträge aus den Excel-Beispielen zum Thema "zählenwenn mit mehreren Bedingungen"