Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
328to332
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
328to332
328to332
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Formelproblem mit wenn...und...dann

Formelproblem mit wenn...und...dann
29.10.2003 11:29:48
Jutta
Hallo,

ich habe in Zelle "A12" das Datum "Aug 02" und in Zelle "B12" das Datum "Okt 03".

Per Formel :
=(JAHR(B11-A11)-1900)*12+MONAT(B11-A11)

lasse ich die Differenz der Monate rechnen. In diesem Fall "15".

Wenn nun in den Zellen "A13" und "B13" noch nichts eingetragen ist, wird als Ergebnis "1" in "C13" ausgewiesen.

Ich möchte aber, dass dann nichts in "C13" steht.

Mit wenn..und...dann habe ich es nicht geschafft.

Gruß

Jutta

9
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Formelproblem mit wenn...und...dann
29.10.2003 11:32:47
Lionel
Wenn(C13=1;"";(JAHR(B11-A11)-1900)*12+MONAT(B11-A11))

Damit sollte es gehen :D
AW: Formelproblem mit wenn...und...dann
29.10.2003 11:42:40
Roland
Ich denke

WENN (B13="";"";(JAHR(B11-A11)-1900)*12+MONAT(B11-A11))

müsste eher stimmen, da bei Lionel´s Lösung auch nichts stehen würde, falls die Differenz der Monate eins betragen würde.

Probiers aus

Roland
AW: Formelproblem mit wenn...und...dann
29.10.2003 12:54:52
Celia
Hallo Roland,

stimmt, so funktioniert es.
Danke !

Gruß
Celia
AW: Formelproblem mit wenn...und...dann
30.10.2003 12:08:04
Roland
Freut mich, dass ich dir helfen konnte.

Gruß
Roland
AW: Formelproblem mit wenn...und...dann
29.10.2003 12:56:18
Celia
Hallo Lionell,

so hat's nicht ganz funktioniert (es kann ja auch einmal "1" richtig sein).
Die Lösung von Roland hat funktioniert.

Danke für Deine Hilfe

Gruß
Celia
Anzeige
AW: Formelproblem mit wenn...und...dann
29.10.2003 12:03:47
Lionel
=WENN(ODER(A13="";B13="");"";(JAHR(B11-A11)-1900)*12+MONAT(B11-A11))

So, hat zwar gedauert, aber das ist es nun ganz sicher
:D
Tut mir leid hatte anfangs das Problem falsch verstanden.
AW: Formelproblem mit wenn...und...dann
29.10.2003 12:59:22
Celia
Hallo Lionell,

Danke ! Mit der Version klappt es jetzt natürlich auch.

Gruß

Celia
AW: Formelproblem mit wenn...und...dann
29.10.2003 13:01:49
Bernhard
Um auch meinen Senf dazugeben zu können:

Jutta bist Du Dir sicher, daß die Differenz bei Deinem Beispiel "15" ist?
Sollte sie nicht eher "14" sein?

Probiers mal mit dieser Formel:
=WENN(ODER(A12="";B12="");"";(JAHR(B12)-JAHR(A12))*12+MONAT(B12)-MONAT(A12))

Gruß
Bernhard
Anzeige
AW: Formelproblem mit wenn...und...dann
29.10.2003 13:12:40
Jutta
Hallo Bernhard,

das liegt daran, dass ich als Datum "1.8.02" eingeben habe und da kommt "15" raus.
Bei "31.8.02" z.B. kommt dann "14" raus.

Danke für Deine Hilfe !

Gruß

Jutta

334 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige