Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
296to300
296to300
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Mittelwert mit Bedingung

Mittelwert mit Bedingung
25.08.2003 12:04:24
Markus
Guten Tag,

ich brauche mal bitte Eure Hilfe.

Und zwar habe ich in Spalte A das Alter stehen

15
36
97
41

Und in Spalte B zugeordnete Zahlen

15 1
36 2
97 3
41 1

Ich möchte nun den Mittelwert bilden unter abhängigkeit der Spalte B

Also, es soll z.B.: der Mittelwert von 15 und 41 gebildet werden, weil ja in Spalte diese zwei Personen in die gleiche Personengruppe fallen.

Mit Summewenn kann ich es nicht machen weil ich die ganze Spalte A und B als Bereich nehmen möchte und daher nicht weiss wieviele Einträge drin sind.

und Leerzellen sind ganz auch nicht drin


Danke schonmal

Markus

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
=mittelwert - ARRAY
25.08.2003 12:19:54
snickers
Hi Markus


{=MITTELWERT(WENN(B1:B999=1;A1:A999))}

ARRAY-Formel: die geschweifte Klammern nicht eingeben, sondern die Formeleingabe abschließen mit Strg+Umsch+Enter



snickers


warum geht das nicht mit:
25.08.2003 12:31:23
Markus
=MITTELWERT(WENN(E:E=1;C:C))

Ich brauche die ganze Spalte, aber da kommt bei o.g. Formel #Zahl, wie kann ich dies machen

Danke nochmals

Markus


habe was, aber es geht nicht richtig
25.08.2003 12:38:48
Markus
habe mir jetzt meine Formel angepasst:

=MITTELWERT(WENN(UND(E2:E65536=allgemein!$C$12;H2:H65536="N");C2:C65536))

Nur sobald ich eine zweite bedingung reinnehme kommt null raus.

Wie geht diese Mittelwertberechnung mit zwei Bedingungen?


Danke

Markus


Anzeige
AW: habe was, aber es geht nicht richtig
25.08.2003 12:45:10
ingo
HAllo Markus,
UND-Funktion in Matrixfunktionen funzt manchmal nicht wirklich, deshalb lieber:

=MITTELWERT(WENN((E2:E65536=allgemein!$C$12)*(H2:H65536="N")=1;C2:C65536))

Ich hoffe, das hilft...

Gruß Ingo


ein problem besteht noch...
25.08.2003 12:52:38
Markus
und zwar bringt mir excel, wenn nur ein Wert gefunden wurde

#DIV/0 --> aber ich teile doch gar nicht.

Was kann ich antstatt des * nehmen um die zweite bedingung hinzubekommen.

Markus


summenprodukt()
25.08.2003 13:01:54
ingo
Hallo Markus,
prinzipiell teilst Du natürlich doch (mittelwert=summe/anzahl)

das kannst Du natürlich auch einzeln berechnen:

=wenn(summenprodukt((E2:E65536=allgemein!$C$12)*(H2:H65536="N") )=0;"kein Wert vorhanden";
summenprodukt((E2:E65536=allgemein!$C$12)*(H2:H65536="N")*(C2:C65536)) /
summenprodukt((E2:E65536=allgemein!$C$12)*(H2:H65536="N")))

sollte so funktionieren

gruß ingo


Anzeige
wenn(... - fordert Eingabe der Zeilen!
25.08.2003 12:45:41
snickers
Hi Markus

die wenn-Verschachtelung fordert die Eingabe der Zeilen-Nr.
Ich hab auch mal mit Summenprodukt versucht - aber auch dort muss man die Zeilen-Nr. eingeben.
Als Ausweg bleibt: gib immer die 65536 als letzte Zeilen-Nr. ein oder lass in einer Hilfszelle die letzte Zeilen-Nr. herausfinden (z.B. mit =Anzahl2(A:A)) und arbeite mit INDIREKT
=Mittelwert(wenn(indirekt("B1:B"&letzte Zeile)=1;indirekt("A1:A"&letzte Zeile))
natürlich auch wieder als ARRAY-Formel

snickers

snickers


334 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige