Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert berechnen ohne Nullwerte

Betrifft: Mittelwert berechnen ohne Nullwerte von: Harald
Geschrieben am: 31.08.2004 14:58:08

Hallo!

Eine Frage:

Wie berechnet man im Excel den Mittel von A1:A10 ohne Nullwerte!

Zum Beispiel:

A1-A5 sind Zahlenwerte

A6 = 0

A7 - A10 sind wieder Zahlenwerte

Wie kann man die 0 aus der Mittelwertberechnung ausnehmen?

mfg

  


Betrifft: AW: Mittelwert berechnen ohne Nullwerte von: heikoS
Geschrieben am: 31.08.2004 15:01:30

Hallo Harald,

=SUMME(A1:A10)/ZÄHLENWENN(A1:A10;"<>0")


Gruß Heiko


  


Betrifft: AW: sieh und staune ;-) von: FP
Geschrieben am: 31.08.2004 15:33:05

Hallo Heiko,

Tabelle2
 ABCDE
11 3,85714286 27
22 4,567
33   3,85714286
40    
5     
66    
77    
88    
Formeln der Tabelle
C1 : =SUMME(A1:A10)/ZÄHLENWENN(A1:A10;"<>0")
E1 : =SUMME(A1:A10)
C2 : {=MITTELWERT(WENN(A1:A10<>0;A1:A10))}
D2 : =ZÄHLENWENN(A1:A10;">0")
E2 : =ZÄHLENWENN(A1:A10;"<>0")
E3 : =E1/E2

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Servus aus dem Salzkammergut
Franz


  


Betrifft: @Franz von: heikoS
Geschrieben am: 31.08.2004 16:17:55

Hallo Franz,

i.O. Allerdings hatte Harald nur von 0 geschrieben und nicht von Leerzellen. Aber stimmt schon, sollte gleich mit drin sein. Hast ja recht. Schande über mein Haupt.


Gruß Heiko


  


Betrifft: AW: Mittelwert berechnen ohne Nullwerte von: Karl
Geschrieben am: 31.08.2004 15:02:13

Probier mal:

=SUMME(A1:A10)/ZÄHLENWENN(A1:A10;"<>0")


Der Karl


 

Beiträge aus den Excel-Beispielen zum Thema "Mittelwert berechnen ohne Nullwerte"