Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
824to828
824to828
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Zählen ohne Duplikate mit 2 Bedingungen

Zählen ohne Duplikate mit 2 Bedingungen
06.12.2006 11:49:01
daniel
Hallo Freunde,
habe ein Problem. Meine Tabelle sieht etwa so aus:
Spalte A B C G
Kunde Datum abgeschlossen x
A 01.11.2006 x
A 08.11.2006 x
B 06.12.2006 x
C 10.11.2006 x
A 23.11.2006
A 14.09.2006 x
Nun möchte ich die Anzahl aller Kunden die z.B. im Monat Nov. 2006 mind. ein Projekt abgeschlossen haben. Das heißt es soll z.B. im obigen Beispiel der Kunde A nur den Wert 1 Liefern (da mind. 1 Projekt im Nov)
Folgende Formel liefert mir bereits die Anzahl der Kunden die überhaupt mind. ein Projekt abgeschlossen haben.
In G1 befindet sich nur den Bezugspunkt zu "x".
=SUMME((VERGLEICH(C1:C10&A1:A10;C1:C10&A1:A10;0)=ZEILE(1:10)*(C1:C10=G1)*(A1:A10""))*1)
Ich danke Euch schon mal vielmals
Daniel

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zählen ohne Duplikate mit 2 Bedingungen
06.12.2006 12:08:09
Mac4
Hallo Daniel,
das korrekte Ergenis wäre also 2 - A und C haben mind. 1 abgeschlossenes Projekt im Nov, oder?
Dann so (in H1 steht der Monat - hier 11):
=SUMME((VERGLEICH(C1:C10&A1:A10&MONAT(B1:B10);C1:C10&A1:A10&MONAT(B1:B10);0)=ZEILE(1:10))*(C1:C10=G1)*(MONAT(B1:B10)=H1))
Marc
AW: Zählen ohne Duplikate mit 2 Bedingungen
06.12.2006 13:45:21
Daniel
Hallo Marc,
vielen Dank für die scnelle Antwort. Das ist richtig. Leider kriege ich die Fehlermeldung #Wert.
Ich hab mal die Datei hochgeladen:
https://www.herber.de/bbs/user/38770.xls
Wer super, wenn das jemand hinkriegen könnte.
LG
Daniel
Anzeige
AW: Zählen ohne Duplikate mit 2 Bedingungen
06.12.2006 13:50:50
Mac4
Hi Daniel,
Du hast aber die Formel mit Strg+Shift+Enter abgeschlossen (Matrixformel), oder?
Falls dann immer noch der Fehler auftritt - ich kann leider die Datei nicht öffnen (unsere EDV-Fuzzies haben da so eine Paranoia). Dann ginge noch zumailen (Mac_4@Web.de).
Marc
AW: Zählen ohne Duplikate mit 2 Bedingungen
06.12.2006 14:12:50
Daniel
Hi Marc,
ja, hab ich. Bringt eine Fehlermeldung. Mmmmh hättest Du noch eine Idee?
Schönen Dank für Deine Hilfe
Daniel
AW: Zählen ohne Duplikate mit 2 Bedingungen
06.12.2006 14:15:46
Mac4
Wie gesagt - mail sie mir mal zu!
Marc
AW: Zählen ohne Duplikate mit 2 Bedingungen
06.12.2006 16:34:36
Mac4
Hi,
hier die Datei zurück - Dein Fehler lag in den ungleichen Bereichsgrößen!
Marc
https://www.herber.de/bbs/user/38780.xls
Anzeige
AW: Zählen ohne Duplikate mit 2 Bedingungen
10.12.2006 17:33:13
Daniel
Hallo Marc,
vielen lieben Dank für Deine Hilfe. Du hast mir dabei sehr geholfen. Wenn ich dir mal wo behilflich sein kann. Schick mir einfach eine Email
Lieben Gruß
Daniel

333 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige