Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Formartierung von doppelten Werten mit A

Formartierung von doppelten Werten mit A
26.01.2022 13:22:00
doppelten
Hallo,
nachdem ich heute den ganzen Tag erfolglos rumprobiert habe, die richtige Formel bzw. Herangehensweise für mein Problem zu finden, frage ich einfach mal die Experten :)
Ich habe einen Datensatz, den ich auf Fehler überprüfen möchte. Ich möchte, dass mir die Zellen angezeigt werden, die in Spalte A doppelt sind, aber nicht in Spalte G doppelt sind. Die Daten sehen wie folgt aus:
Spalte A Spalte G
100 5200
101 5285
102 5299
102 5299
103 5365
104 5368
104 5368
104 5368
105 5389
106 5395
106 5397
107 5411
107 5411
107 5415
107 5415
107 5415
Der Fehler wäre bei Wert 106 (gleicher Wert Spalte A, verschiedene Werte Spalte G), kann aber auch wie bei Wert 107 aussehen (Wert 107, mehrfach in Spalte A was ok ist, aber mit zwei verschiedenen Werten in Spalte G die aber auch mehrfach vorhanden sind).
Den Fehler bei Wert 106 kann ich mit folgender Formel finden:
=UND(ZÄHLENWENN($A$1:$A$100;A1)>1;ZÄHLENWENNS($A$1:$A$100;A1;$G$1:$G$100;G1) Diese Formel funktioniert aber nicht für den Fehler in Wert 107.
Vielen Dank für eure Hilfe!

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Formartierung von doppelten Werten mit A
26.01.2022 13:44:53
doppelten
Hallo
als Formel für

I1  :     =WENN(SUMMENPRODUKT(($A$1:$A$1000&"|"&$G$1:$G$1000=A1&"|"&G1)*(1))=SUMMENPRODUKT(($A$1:$A$1000=A1)*(1));"";"Mehrfach")
Kannst du ja als Grundlage für Bedingte Formatierung nehmen
LG UweD
AW: Formartierung von doppelten Werten mit A
26.01.2022 13:55:22
doppelten
Hallo Sarah,
man kann mit dem Zählenwenn auch die Ungleichheit zählen:

=ZÄHLENWENNS($A$1:$A$100;A1;$G$1:$G$100;""&G1)>1
VG
Yal
Korrektur >0
26.01.2022 13:59:23
Yal

=ZÄHLENWENNS($A$1:$A$100;A1;$G$1:$G$100;""&G1)>0
und nicht

=ZÄHLENWENNS($A$1:$A$100;A1;$G$1:$G$100;""&G1)>1

Anzeige
AW: Korrektur >0
27.01.2022 11:10:47
Sarah
Vielen vielen Dank! funktioniert super!

305 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige