Doppelte Einträge löschen bis auf einen

Bild

Betrifft: Doppelte Einträge löschen bis auf einen
von: NewtonZ4
Geschrieben am: 28.07.2015 07:19:47

Hallo Zusammen,
in meiner Excel Tabelle befinden sich in Spalte A doppelte Einträge.
Die Tabelle ist nach Spalte A alphabetisch sortiert. Jetzt sollen alle Doppelte Einträge gelöscht werden bis auf der Oberste der jeweiligen Doppelten.
Hoffe ich konnte es erklären
Beispiel:
aeDDiek
aeDDiek
aeDDiek
aeDDiek
aeDDiek
aeDDiek
Die unteren 5 Einträge sollen gelöscht werden und der obere soll stehen bleiben.

Bild

Betrifft: AW: Doppelte Einträge löschen bis auf einen
von: Daniel
Geschrieben am: 28.07.2015 08:07:46
Hi
Dafür gibt es die Menüfunktion
Daten - Datentools - Duplikate entfernen
Gruß Daniel

Bild

Betrifft: AW: Doppelte Einträge löschen bis auf einen
von: NewtonZ4
Geschrieben am: 28.07.2015 08:20:28
Wenn ich diese Funktion nutze passiert folgendes. Es werden die doppelten Einträge gelöscht und die verbleibenden werden neu sortiert und nach oben geschoben. Das soll gerade nicht passieren. Es sollen die doppelten Einträge gelöscht werden und der oberste Eintrag soll stehen bleiben.

Bild

Betrifft: Hilfsspalte
von: RPP63
Geschrieben am: 28.07.2015 08:12:16
Hallo!
Deine Werte in Spalte A ab Zeile 2.
Hilfsspalte B
Formel ab B2 herunterziehen: =ZÄHLENWENN(A$2:A2;A2)>1
(wenn Spalte A sortiert ist, geht auch die schnellere Formel: =A2<>A1)
Ersteres nach WAHR filtern, letzteres nach FALSCH
sichtbare Zeilen ab Zeile 2 löschen
Hilfsspalte löschen
Gruß Ralf

Bild

Betrifft: AW: Hilfsspalte
von: NewtonZ4
Geschrieben am: 28.07.2015 08:22:45
Es dürfen nicht die Zeilen gelöscht werden, weil in den Spalten B, C usw. noch Informationen stehen. Es sollen nur in Spalte A die doppelten Einträge gelöscht werden und der oberste oder erste Eintrag soll in Stehen bleiben. Nur Inhalte löschen keine Zellen oder Spalten

Bild

Betrifft: AW: Hilfsspalte
von: Daniel
Geschrieben am: 28.07.2015 08:32:06
Hi
Mach es di wie Ralf es beschrieben hat.
Markiere dann nur die Spalte A und lösche dort die Inhalte.
Die ausgeblendeten Zeilen werden nicht bearbeitet, dh deren Inhalte werden nicht mit gelöscht und sind nach dem Aufheben des Filters wieder da.
Gruß Daniel

Bild

Betrifft: AW: Hilfsspalte
von: NewtonZ4
Geschrieben am: 28.07.2015 09:52:31
geil...wie einfach,funktioniert super.
Besten dank :-)

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Doppelte Einträge löschen bis auf einen"