Wenn mit 2 Bedingungen

Bild

Betrifft: Wenn mit 2 Bedingungen
von: Ilka
Geschrieben am: 27.11.2003 16:38:44

Hallo,

seit Tagen versuche ich eine Formel aufzustellen, welche mir bei einer Stundenberechnung in einem bestimmten Zeitraum, von min.13:00Uhr bis min. 21:00Uhr, keine halbe Stunde abzieht. Mit meinen Formeln scheint
Excel sich immer nur nach einer Bedingung zu richten. Ich habe 2 Beispiele mal aufgelistet, dort könnt Ihr vielleicht meine Fehler entdecken und mir helfen.

Beispiel 1
Beginn Ende
6:00 16:30
=WENN(D63>=ZEIT(21;0;0)+C63>=ZEIT(13;0;0);I63;I63-ZEIT(0;30;0))

Beispiel 2
Beginn Ende
13:45 22:00
=WENN(UND(D35>=ZEIT(21;0;0);C35>=ZEIT(13;0;0);I35;I35-ZEIT(0;30;0))

Danke

Gruß Ilka

Bild


Betrifft: AW: Wenn mit 2 Bedingungen
von: Richard Weber
Geschrieben am: 27.11.2003 16:52:00

Wenn ich es auf die Schnelle richtig verstehe,
glaube ich, dass Du für Deine Wünsche die falsche Logik verwendest.

Um das Zeitfenster 13:00 bis 21:00 zu treffen, müßte die Formel eher so heissen:
=WENN(UND(D35>=ZEIT(13;0;0); C35<=ZEIT(21;0;0)); ; ) .... oder ähnlich,
Wesentlich ist die mit UND verknüpfte größer/kleiner-Abfrage um eine "Schnittfenster" zu bekommen.

Richard



Bild


Betrifft: wenn ich dich richtig verstehe...
von: oos
Geschrieben am: 27.11.2003 17:01:02

Hallo Ilka,

dann muss deine Formel nicht >=Zeit(21;0;0)... lauten, sondern <=Zeit(21;0;0)... ,
denn du willst ja einen Zeitraum zwischen 13 Uhr und 21 Uhr ansprechen - also größer 13 Uhr und kleiner 21 Uhr.

Hoffe es hilft dir weiter ;-)

G.a.BY

Niko


Bild


Betrifft: AW: Wenn mit 2 Bedingungen
von: FP
Geschrieben am: 27.11.2003 20:07:52

Hallo Ilka,

geht es wirklich darum, dass zwischen 13:00 und 21:00 kein Abzug von 1/2 Stunden erfolgen soll, oder soll ab 8 Stunden Arbeitszeit kein Abzug erfolgen?

Excel Jeanie HTML
Formeln der Tabelle
C2 : =B2-A2-((A2<=13/24)+(B2>=21/24)<2)*1/48
D2 : =(B2-A2)-((B2-A2)<1/3)*1/48
C3 : =B3-A3-((A3<=13/24)+(B3>=21/24)<2)*1/48
D3 : =(B3-A3)-((B3-A3)<1/3)*1/48
C4 : =B4-A4-((A4<=13/24)+(B4>=21/24)<2)*1/48
D4 : =(B4-A4)-((B4-A4)<1/3)*1/48
C5 : =B5-A5-((A5<=13/24)+(B5>=21/24)<2)*1/48
D5 : =(B5-A5)-((B5-A5)<1/3)*1/48
C6 : =B6-A6-((A6<=13/24)+(B6>=21/24)<2)*1/48
D6 : =(B6-A6)-((B6-A6)<1/3)*1/48
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   Servus aus dem Salzkammergut Franz

Bild

Beiträge aus den Excel-Beispielen zum Thema " Wenn mit 2 Bedingungen"