Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
360to364
360to364
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Problem mit Wenn-Funktion

Problem mit Wenn-Funktion
12.01.2004 16:42:02
Dirk
Hallo Leute
Ich habe ein Problem mit einer Wenn Formel!
das heisst wenn die bedingung erfüllt ist, soll der Wert der Zelle in der die Wenn formel sich befindet verändert werden, wenn sie nicht erfüllt ist soll sie den wert nicht verändern!
Geht das denn?
Danke für jede Hilfe
Gruss
dirk
wenn ihr lust habt schaut euch mal meine beispiel datei an!
sie ist wichtig zum weiteren verständnis!
https://www.herber.de/bbs/user/2883.xls
!auch die Kommentare beachten!
Bsp (allgemein) - Wenn Formel - steht in b2
=wenn(a1=a2;b1;*problem* sonst lasse alten Werte der Zelle stehen)
Bei mir wird wenn die Bedingung nicht erfüllt ist der Wert '0' übergeben!
danke für jeden rat!
gruss dirk

9
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Problem mit Wenn-Funktion
12.01.2004 16:54:04
leben
Die Wenn-Funktion sieht drei Felder vor:
(Wenn-Bedingung, Dannfolge, Sonstfolge)
Für deine Zelle C7 heißt das =WENN($A$2=B7;$B$2;C7)
- lbs -
AW: Problem mit Wenn-Funktion
12.01.2004 17:07:21
Mark Schmidt
Also so wie ich dich verstanden habe, werden in Spalte C auch die Werte per VBA eingelesen. Wenn das so ist, dann hätte ich eine Lösung, ist vielleicht nicht die Beste, aber es würde funktionieren.
Also du könntest die Formel in Spalte D schreiben und Spalte C ausblenden, soferm das möglich ist. Dann prüfst du halt in Spalte D ob A2 mit B7 übereinstimmt, wenn ja soll C7 eingetragen werden, sonst nichts (=WENN($A$2=$B7;$C7;"")
Hoffe es hilft erstmal. Bis bald Mark
Anzeige
AW: Problem mit Wenn-Funktion
12.01.2004 17:15:46
Mark Schmidt
Ich nochmal, hatte mich bischer verlesen :) also, hier die richtige Lösung
=wenn($B7=$A$2;$B$2;$C7)
Gruß Mark
Original-datei
12.01.2004 17:36:06
dirk
Du mark
in meiner datei (original)
klappt es nicht!
wenn du willst lade ich diese mal hoch !
wollte das eigentlich vermeiden, weil sie durcheinander ist!
wenn du trotzdem willst!
dann sage bescheid!
gruss
dirk
AW: Problem mit Wenn-Funktion? = vba ???
12.01.2004 17:26:22
Dirk
Hallo Mark
Also per Vba werden eigentlich nur die werte in A2 und B2 übertragen!
*nehmen wir das an*
nun soll halt geprüft werden ob bedingung erfüllt
-> dann neuer Wert sonst
-> lasse den alten Wert stehen!
klappt aber mit deinem tipp nicht!
am besten wäre wenn die "Wenn Fkt. " per Vba gemacht werden würd,
denke ich.
das heisst es werden die daten übertragen und vba geht vielleicht per schleife durch und prüft wann bedingung erfüllt und trägt den wert an die stelle wo bedinung erfüllt!
leider fehlt mir dazu das wissen!
ich hoffe du verstehst was ich meine!
Bsp.
Schleide läuft von 1-10
*jede Zelle(Kunde) bekommt eine Zahl (1-10)
dann wird geprüft und an diese Stelle wert eingetragen!
Dann dürfte es keine Fehler mehr geben!
Gruss
dirk
*ich danke dir erstmal vielleicht hast du einen tipp
wie man das in eine art schleife umwandeln kann!!
gruss dirk
Anzeige
AW: Problem mit Wenn-Funktion? = vba ???
12.01.2004 17:40:12
Mark Schmidt
Sorry, so gut kenn ich mich mit VBA nicht aus, dass ich dir ne Schleife schreiben könnte. Eventuell würde ich das Für jede Prüfung extra hinbekommen, also Zellenweise aber sonst nicht.
Davon aber mal abgesehen, müsste es auch ohne VBA gehen, denn du sagst, dass in Zelle A2 und B2 ein Wert eingetragen wird, also könntest du in Spalte D doch prüfen, ob die Prämissen übereinstimmen, und wenn nicht, soll der Wert der in Spalte C steht eingetragen werden.
Mehr kann ich dir heute leider nicht helfen...
Mark
AW: aus der Online Hilfe
12.01.2004 18:00:12
dirk
Hi peter!
danke erstmal für den artikel ich weiss das ich zirkelbezüge habe!
aber deshalb funktioniert es so weit!
helfen die mir nun weiter ich habe leider nicht so richtig verstanden
was du mir damit sagen willst!
gruss
dirk
*ich drehe noch durch*
teste schon ewig daran
Zulassen Zirkelbezug
12.01.2004 18:16:38
Peter
Hallo Dirk,
Ich hab es mal kurz getestet,
Wenn du im Menü
Extras> Optionen> Berechnung> das Häkchen in "Iteration" setzt,
behält die Zelle den wert, bis die Bedingung stimmt.
Beispiel:
In Zelle C1 =Wenn(A1=A2;B1;C1)
Ich weiss zwar das es funzt, aber bevor du
es anwendest vergewissere dich ob das gut ist!!
Gruss Peter
Anzeige

329 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige