Anzeige
Archiv - Navigation
1276to1280
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

zählenwenn ohne doppelte einträge

zählenwenn ohne doppelte einträge
RonaldoHH
Hallo zusammen,
ich verzweifele gerade und bin mir ganz sicher, dass ich hier eine Lösung finden werde.
in den Zeile a2 : a85 stehen Kundennummern, die auch merhfach vorkommen,
in den Zeilen b2: b85 stehen 3 verschiedene Produkte z.B. A, B, C
Ich möchte errechnen, wieviele KUnden z.B. Produkt A gekauft haben (ohne dass die Kunden doppelt gezählt werden.
Folgende Formel habe ich gefunden, die mir die Anzahl der Kunden errechnet (ohne doppelte)
{=SUMME(WENN(A1:A85"";VERGLEICH(A1:A85;A1:A85;0)=ZEILE(1:85))*1)}
Diese Formel funktioniert allerdings nur dann, wenn ab A1 gezählt wird.
Kann mir jemand sagen, wie ich die beiden Spalten miteinander kombiniere ?
Vielen Dank im voraus !
Gruss Ronaldo

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: zählenwenn ohne doppelte einträge
08.09.2012 09:39:20
hary
Hallo
Vlt. bekommt es ein Formelspezi schoener hin.
Tabelle1
 ABCDE
1IdProdukt  ProduktAnzahl Kunden
21a  a3
32b  b1
41a  c1
54c     
61a     
76a     
82b     
98a     
10         

verwendete Formeln
Zelle Formel Bereich
E2 {=SUMME(WENN($B$2:$B$85=D2;VERGLEICH(WENN($B$2:$B$85=D2;$A$2:$A$85);WENN($B$2:$B$85=D2;$A$2:$A$85);)=ZEILE($1:$84))*1)} $E$2
E3 {=SUMME(WENN($B$2:$B$85=D3;VERGLEICH(WENN($B$2:$B$85=D3;$A$2:$A$85);WENN($B$2:$B$85=D3;$A$2:$A$85);)=ZEILE($1:$84))*1)} $E$3
E4 {=SUMME(WENN($B$2:$B$85=D4;VERGLEICH(WENN($B$2:$B$85=D4;$A$2:$A$85);WENN($B$2:$B$85=D4;$A$2:$A$85);)=ZEILE($1:$84))*1)} $E$4
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 5.30


gruss hary

Anzeige
AW: zählenwenn ohne doppelte einträge
08.09.2012 15:30:51
RonaldoHH
Hi, vielen Dank für Deine Hlfe. Hat mir auf jeden Fall weitergeholfen !
Gruss
Ronaldo

309 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige