Performancesteigerung: Optimierung Formel?

Bild

Betrifft: Performancesteigerung: Optimierung Formel?
von: Olaf
Geschrieben am: 06.11.2015 08:49:15

Guten Morgen zusammen
Habe eine Formel in meinem xls, welche diverse Zellen in Abfolge auf Inhalt gösser 0 überprüft oder leer und den Wert ausgibt. Diese Formel benötige ich x-fach in meiner Datei, mit dem Resultat, dass die Performance zu wünschen übrig lässt...
Hat jemand von Euch eine Idee, wie sich der Code optimieren liesse?
Danke für jede Hilfe.
Olaf
=WENN(E1>0;E1;WENN(D1>0;D1;WENN(C1<>"";C1;WENN(C1="";WENN(B1>0;B1;A1)))))
Beispieldatei hier: https://www.herber.de/bbs/user/101280.xlsx

Bild

Betrifft: AW: Performancesteigerung: Optimierung Formel?
von: SF
Geschrieben am: 06.11.2015 08:58:59
Hola,

=VERWEIS(2;1/(A1:G1>0);A1:G1)
Gruß,
steve1da

Bild

Betrifft: AW: Performancesteigerung: Optimierung Formel?
von: Olaf
Geschrieben am: 06.11.2015 09:10:12
Super, ich danke dir!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Performancesteigerung: Optimierung Formel?"