Microsoft Excel

Herbers Excel/VBA-Archiv

komplexe Matrixformel | Herbers Excel-Forum


Betrifft: komplexe Matrixformel von: Harald
Geschrieben am: 17.11.2009 23:17:43

Hallo,

Ute Otto Name
5 9
9 4

A1=Ute, B1=Otto, C1=Name
A2=5, B2=9, in C2 muss Otto ausgegeben werden weil er den höchsten Wert hat.

Also, den größten Wert von links stehenden Werten ermitteln und dann die Überschrift (Ute, Otto, Evi) ausgeben.
Diese Formel gibt mir schon mal die Spaltennummer zurück in der der größre Wert steht:
=VERGLEICH(KGRÖSSTE(A2:C2;1);A2:C2;0)
Nun müsste ich mit Bereich.Verschieben irgendwie innerhalb der Spalte den obersten Inhalt in dem die Namen Ute bzw Otto stehen ausgeben. Versteht ihr, kann jemand helfen?

Vielen Dank
Harald

  

Betrifft: AW: komplexe Matrixformel von: WalterK
Geschrieben am: 17.11.2009 23:30:22

Hallo,

so vielleicht:
Tabelle1

 ABC
1UteOttoName
259Otto
394Ute

Formeln der Tabelle
ZelleFormel
C2=INDEX($A$1:$B$1;VERGLEICH(MAX(A2:B2); A2:B2;0))
C3=INDEX($A$1:$B$1;VERGLEICH(MAX(A3:B3); A3:B3;0))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Servus, Walter


  

Betrifft: AW: komplexe Matrixformel von: Harald
Geschrieben am: 18.11.2009 17:01:06

Hallo WalterK,

vielen Dank für diese Lösung! Mein Lösungsansatz war wohl nicht brauchbar bzw. umständlich.
Ich verstehe zwar noch nicht warum es geht, aber es funktioniert. Werde mich mit der INDEX-Funktion auseinander setzten weil hiermit vermutlich weitere Lösungen möglich sind die ich bisher zu umständlich angegangen bin.

herzlichen Dank
Harald


  

Betrifft: noch ein wenig kürzer von: Erich G.
Geschrieben am: 17.11.2009 23:58:57

Hi Harald.
oder so:

 ABC
1UteOttoName
259Otto
394Ute

Formeln der Tabelle
ZelleFormel
C2=VERWEIS(2;1/(A2:B2=MAX(A2:B2)); A$1:B$1)
C3=VERWEIS(2;1/(A3:B3=MAX(A3:B3)); A$1:B$1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

(vgl. auch https://www.herber.de/forum/archiv/1116to1120/t1117916.htm#1117970 - von heute)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: noch ein wenig kürzer von: Harald
Geschrieben am: 18.11.2009 17:12:32

Hallo Erich,

vielen Dank für diese Lösung! Für meinen Lösungsansatz schäme ich mich inzwischen schon etwas :-)
Mit der Verweis-Funktion hatte ich auch schon experimentiert, bin aber nicht zu einer Lösung gekommen. Wenn man die Lösung vor Augen hat sieht es immer so einfach aus. Neben der Indexfunktion die WalterK eingesetzt hat werde ich mich jetzt auch mit der Verweisfunktion intensiver beschäftigen.

herzlichen Dank
Harald


Beiträge aus den Excel-Beispielen zum Thema "komplexe Matrixformel"