Tabellenblätter zusammenführen?



Excel-Version: 10.0 (Office XP)
nach unten

Betrifft: Tabellenblätter zusammenführen?
von: Daniel
Geschrieben am: 12.06.2002 - 14:00:25

Ich habe beispielsweise ein Tabellenblatt mit 450 Personendaten (Adresse, Telefonnummer etc.) und ein 2. Tabellenblatt mit der Automarke von 110 Personen aus dem 1. Tabellenblatt. Wie
kann ich diese Daten zum ersten Tabellenblatt hinzufügen?
Eine Schlüsselvariable ist vorhanden (laufende Nummer, bzw. Passwort).

nach oben   nach unten

Re: Tabellenblätter zusammenführen?
von: Hajo
Geschrieben am: 12.06.2002 - 14:02:16

Hallo Daniel

die Schlüsselnummer sollte in Beiden Tabellen die erste Spalte sein. Siehe Dir mal die Funktion SVerweis an.

Gruß Hajo


nach oben   nach unten

Re: Tabellenblätter zusammenführen?
von: Daniel
Geschrieben am: 12.06.2002 - 14:13:09

Hallo Hajo,

könntest Du mir bitte die Verwendung von SVerweis genauer erläutern?
Ich habe also Tabellenblatt1:
A B
ID Name

12345 Martin Müller

UND

Tabellenblatt2:

A B
ID Automarke

12345 Alfa Romeo

und nun?


nach oben   nach unten

Re: Tabellenblätter zusammenführen?
von: Alan Hathway
Geschrieben am: 12.06.2002 - 14:15:47

Hi Daniel,

hier könnte Hajo Dir sicherlich helfen, aber mit einem bisschen Eigeninitiative schaffts Du es allein.
- Hilfe
- Archiv
sind gute Ansätze

Nix für Ungut

Alan Hathway


nach oben   nach unten

Re: Tabellenblätter zusammenführen?
von: Hajo
Geschrieben am: 12.06.2002 - 14:18:37

Hallo Daniel

als da gibts es unterschiedliche möglichkeite. Ich benenne den Bereich wo die Suchdaten stehen mit einem Namen. In Deinen Beispiel Tabelle2 von A1 bis Bxx bekommt den Namen Auto
in Tabele1 C1 schreibst Du folgende Formel
=WENN(ISTFEHLER(SVERWEIS(A1;Auto;2;0));"";SVERWEIS(A1;Auto;2;0))

Die Formel sieht ein wenig lang aus da gleich Fehlerbehandlung drin ist, falls die ID nicht gefunden wird.

Im Prinzip sagt der Sverweis suche den Wert von A1 im Bereich Auto und wenn gefunden zeige den Wert aus der 2 Spalte.

Gruß Hajo


nach oben   nach unten

Re: Ergänzung: Tabellenblätter zusammenführen?
von: Kl@us-M.
Geschrieben am: 12.06.2002 - 14:29:28

Hallo Hajo,
vielleicht sollte man noch darauf hinweisen, dass der Bereich "Auto" sortiert sein muss, damit SVERWEIS greifen kann (bitte diese Ergänzung nicht übel nehmen !!!).
Gruss
Klaus-Martin

nach oben   nach unten

Re: Ergänzung: Tabellenblätter zusammenführen?
von: Hajo
Geschrieben am: 12.06.2002 - 14:34:13

Hallo Klaus-Martin

kein Problem.

Gruß Hajo


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "gleiche Zellen in allen Zeilen verbinden"